[PATCH v6 1/8] reset: rename update_refs to reset_refs
- From
Brad King <brad.king@kitware.com>
- Date
- Sep 10, 2013, 00:57 UTC
- Message-ID
- <caa29a576f30be135956073ccab6534d0877a418.1378773895.git.brad.king@kitware.com>
- In-Reply-To
- <cover.1378773895.git.brad.king@kitware.com>
The function resets refs rather than doing arbitrary updates. Rename it to allow a future general-purpose update_refs function to be added.
Signed-off-by: Brad King <brad.king@kitware.com> --- builtin/reset.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/builtin/reset.c b/builtin/reset.c index 5e4c551..88b4fde 100644 --- a/builtin/reset.c +++ b/builtin/reset.c @@ -226,7 +226,7 @@ static void parse_args(struct pathspec *pathspec, prefix, argv); } -static int update_refs(const char *rev, const unsigned char *sha1) +static int reset_refs(const char *rev, const unsigned char *sha1) { int update_ref_status; struct strbuf msg = STRBUF_INIT; @@ -357,7 +357,7 @@ int cmd_reset(int argc, const char **argv, const char *prefix) if (!pathspec.nr && !unborn) { /* Any resets without paths update HEAD to the head being * switched to, saving the previous head in ORIG_HEAD before. */ - update_ref_status = update_refs(rev, sha1); + update_ref_status = reset_refs(rev, sha1); if (reset_type == HARD && !update_ref_status && !quiet) print_new_head_line(lookup_commit_reference(sha1));
-- 1.8.4.rc3