Re: [StGIT PATCH 2/5] Rename Repository.head to Repository.head_ref
- From
- Catalin Marinas <catalin.marinas@gmail.com>
- Date
- Jun 5, 2008, 12:06 UTC
- Message-ID
- <b0943d9e0806050506u25c0441cy86caaec708ba838f@mail.gmail.com>
- In-Reply-To
- <20080605115820.GA27430@diana.vm.bytemark.co.uk>
2008/6/5 Karl Hasselström <kha@treskal.com>:
Show 10 quoted lines
> On 2008-06-05 12:49:15 +0100, Catalin Marinas wrote: > ( Did you run the test suite on your patches? I always do something > like this (untested -- I have this command in my bash history on > another computer) > > $ stg pop -a > $ while make test; do stg push || break; done > > before sending out patches. It takes a few minutes per patch, but > it's fully automatic. )
Not really. It would be good to have a Makefile target for this, something like "test_patches". I'll add it.
-- Catalin