Re: [StGIT PATCH 2/5] Rename Repository.head to Repository.head_ref
- From
Karl Hasselström <kha@treskal.com>
- Date
- Jun 5, 2008, 12:46 UTC
- Message-ID
- <20080605124620.GA28995@diana.vm.bytemark.co.uk>
- In-Reply-To
- <b0943d9e0806050506u25c0441cy86caaec708ba838f@mail.gmail.com>
On 2008-06-05 13:06:39 +0100, Catalin Marinas wrote:
Show 14 quoted lines
> 2008/6/5 Karl Hasselström <kha@treskal.com>: > > > ( Did you run the test suite on your patches? I always do > > something like this (untested -- I have this command in my bash > > history on another computer) > > > > $ stg pop -a > > $ while make test; do stg push || break; done > > > > before sending out patches. It takes a few minutes per patch, but > > it's fully automatic. ) > > Not really. It would be good to have a Makefile target for this, > something like "test_patches". I'll add it.
Good idea. But consider the case where the user doesn't want to test all the patches -- maybe you could give make FIRST_PATCH and/or LAST_PATCH parameters? (Defaulting to all patches, of course.)
--
Karl Hasselström, kha@treskal.com
www.treskal.com/kalle