Re: [StGIT PATCH 2/5] Rename Repository.head to Repository.head_ref
On 2008-06-04 22:13:25 +0100, Catalin Marinas wrote:
> This is to avoid confusion with the Stack.head function which
> returns a commit object rather than a file name.
A much better name. But you don't fix any callers -- aren't there any?
> The patch also changes the "new" function to use stack.head directly
> rather than via the Repository.refs... object.
Oh, here's a caller. But just one.
--
Karl Hasselström, kha@treskal.com
www.treskal.com/kalle