Re: [StGIT PATCH 2/5] Rename Repository.head to Repository.head_ref
On 2008-06-05 12:49:15 +0100, Catalin Marinas wrote:
Show 8 quoted lines
> 2008/6/5 Karl Hasselström <kha@treskal.com>:
>
> > A much better name. But you don't fix any callers -- aren't there any?
>
> There was actually another caller but missed it since I worked on a
> bigger initially. The stack.Repository.current_branch uses it but
> this was later moved to git.Repository.current_branch_name. I'll add
> in case we ever need to bisect.
Ah, good.
( Did you run the test suite on your patches? I always do something
like this (untested -- I have this command in my bash history on
another computer)
$ stg pop -a
$ while make test; do stg push || break; done before sending out patches. It takes a few minutes per patch, but
it's fully automatic. )
--
Karl Hasselström, kha@treskal.com
www.treskal.com/kalle