From: Catalin Marinas Date: Thu, 05 Jun 2008 12:06:39 GMT Subject: Re: [StGIT PATCH 2/5] Rename Repository.head to Repository.head_ref Message-ID: In-Reply-To: <20080605115820.GA27430@diana.vm.bytemark.co.uk> 2008/6/5 Karl Hasselström : > On 2008-06-05 12:49:15 +0100, Catalin Marinas wrote: > ( Did you run the test suite on your patches? I always do something > like this (untested -- I have this command in my bash history on > another computer) > > $ stg pop -a > $ while make test; do stg push || break; done > > before sending out patches. It takes a few minutes per patch, but > it's fully automatic. ) Not really. It would be good to have a Makefile target for this, something like "test_patches". I'll add it. -- Catalin