Re: [StGIT PATCH 2/5] Rename Repository.head to Repository.head_ref
- From
- Catalin Marinas <catalin.marinas@gmail.com>
- Date
- Jun 5, 2008, 11:49 UTC
- Message-ID
- <b0943d9e0806050449s4b55d06cu1b7701a562c7a6ba@mail.gmail.com>
- In-Reply-To
- <20080605064633.GB23209@diana.vm.bytemark.co.uk>
2008/6/5 Karl Hasselström <kha@treskal.com>:
Show 6 quoted lines
> On 2008-06-04 22:13:25 +0100, Catalin Marinas wrote: > >> This is to avoid confusion with the Stack.head function which >> returns a commit object rather than a file name. > > A much better name. But you don't fix any callers -- aren't there any?
There was actually another caller but missed it since I worked on a bigger initially. The stack.Repository.current_branch uses it but this was later moved to git.Repository.current_branch_name. I'll add in case we ever need to bisect.
-- Catalin