Re: [PATCH] Refactor recv_sideband()
- From
Nicolas Pitre <nico@fluxnic.net>
- Date
- Jun 14, 2016, 15:04 UTC
- Message-ID
- <alpine.LFD.2.20.1606141059420.1714@knanqh.ubzr>
- In-Reply-To
- <alpine.DEB.2.20.1606141542040.22630@virtualbox>
On Tue, 14 Jun 2016, Johannes Schindelin wrote:
Show 21 quoted lines
> Hi, > > On Mon, 13 Jun 2016, Nicolas Pitre wrote: > > > On Mon, 13 Jun 2016, Lukas Fleischer wrote: > > > > > Improve the readability of recv_sideband() significantly by replacing > > > fragile buffer manipulations with more sophisticated format strings. > > > Also, reorganize the overall control flow, remove some superfluous > > > variables and replace a custom implementation of strpbrk() with a call > > > to the standard C library function. > > > > > > Signed-off-by: Lukas Fleischer <lfleischer@lfos.de> > > > > The previous code was a total abomination, even if I happen to know who > > wrote it. > > Let's give Junio a break, okay? He does a kick-ass job at maintaining Git. > What we see here is simply good software development, nothing more, > nothing less: an initial, working code being improved. No need to make the > original author feel bad... :-)
In case my sarcasm wasn't clear, _I_ am the author of the alluded abomination.
Nicolas