Re: [PATCH] Refactor recv_sideband()
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Jun 14, 2016, 15:30 UTC
- Message-ID
- <alpine.DEB.2.20.1606141729080.22630@virtualbox>
- In-Reply-To
- <alpine.LFD.2.20.1606141059420.1714@knanqh.ubzr>
Hi Nico,
On Tue, 14 Jun 2016, Nicolas Pitre wrote:
Show 24 quoted lines
> On Tue, 14 Jun 2016, Johannes Schindelin wrote: > > > On Mon, 13 Jun 2016, Nicolas Pitre wrote: > > > > > On Mon, 13 Jun 2016, Lukas Fleischer wrote: > > > > > > > Improve the readability of recv_sideband() significantly by > > > > replacing fragile buffer manipulations with more sophisticated > > > > format strings. Also, reorganize the overall control flow, remove > > > > some superfluous variables and replace a custom implementation of > > > > strpbrk() with a call to the standard C library function. > > > > > > > > Signed-off-by: Lukas Fleischer <lfleischer@lfos.de> > > > > > > The previous code was a total abomination, even if I happen to know > > > who wrote it. > > > > Let's give Junio a break, okay? He does a kick-ass job at maintaining > > Git. What we see here is simply good software development, nothing > > more, nothing less: an initial, working code being improved. No need > > to make the original author feel bad... :-) > > In case my sarcasm wasn't clear, _I_ am the author of the alluded > abomination.
Sorry, I did not catch that. I just looked at 583b7ea31b7c16f872b178d541591ab816d16f85 and felt that we could be nicer to Junio...
Ciao, Johannes