Re: [PATCH v2 06/10] sequencer: simplify handing of fixup with conflicts
- From
Oswald Buddenhagen <oswald.buddenhagen@gmx.de>
- Date
- Jul 13, 2026, 14:09 UTC
- Message-ID
- <alTxn7MmX3aH_7gp@ugly.lan>
- In-Reply-To
- <26dc48951cea663080bacf7d8d4760528125cbf5.1783948637.git.phillip.wood@dunelm.org.uk>
On Mon, Jul 13, 2026 at 02:17:23PM +0100, Phillip Wood wrote:
Show 5 quoted lines
>Commit e032abd5a0 (rebase: fix rewritten list for failed pick, >2023-09-06) introduced an early return when res == -1, so if we enter >this conditional block then res is positive. After the last couple >of commits the only possible positive value is 1 so we can simplify >the code by removing the conditional call to intend_to_amend() and
>call it error_with_patch() instead. >
that part makes no sense, subverting the argumentation. (as-is, i actually can't follow the logic, but i suppose it would be clear with (much) more diff context. i'm not sure whether the commit message is supposed to substitute for that, or the reviewer is supposed to deal with that on their end.)