Re: [PATCH v6 3/9] ref: initialize target name outside of check functions
- From
Patrick Steinhardt <ps@pks.im>
- Date
- Nov 6, 2024, 13:14 UTC
- Message-ID
- <Zytrn-WWLIupKZ6m@pks.im>
- In-Reply-To
- <Zyth0-rUAj83Rz6F@ArchLinux>
On Wed, Nov 06, 2024 at 08:32:19PM +0800, shejialuo wrote:
Show 16 quoted lines
> On Tue, Nov 05, 2024 at 08:11:46AM +0100, Patrick Steinhardt wrote: > > On Mon, Oct 21, 2024 at 09:34:31PM +0800, shejialuo wrote: > > > In order not to do repeat calculation, rename "refs_check_dir" to > > > "target_name". And in "files_fsck_refs_dir", create a new strbuf > > > "target_name", thus whenever we handle a new target, calculate the > > > name and call the check functions one by one. > > > > "target_name" is somewhat of a weird name. I'd expect that this is > > either the path to the reference, in which case I'd call this "path", or > > the name of the reference that is to be checked, in which case I'd call > > this "refname". > > > > I felt quite hard to name this variable when I wrote the code. "refname" > is not suitable due to we may check the reflog later by calling > "files_fsck_refs_dir" function.
I anticipate that we'll likely have separate infra for checking reflogs as they are both stored in a different directory and because their format is completely different compared to normal refs. So there isn't really too much of a point to plan ahead for sharing logic here, I'd think, and thus "refname" might be a better fit. If that changes in the future we can still refactor the code.
Patrick