Re: [PATCH v5 6/9] ref: add escape check for the referent of symref
- From
Patrick Steinhardt <ps@pks.im>
- Date
- Oct 7, 2024, 09:26 UTC
- Message-ID
- <ZwOpR2kQ0cWb_7Kq@pks.im>
- In-Reply-To
- <ZwOffN9UWX1gP0gy@ArchLinux>
On Mon, Oct 07, 2024 at 04:44:44PM +0800, shejialuo wrote:
Show 15 quoted lines
> On Mon, Oct 07, 2024 at 08:58:55AM +0200, Patrick Steinhardt wrote: > > On Sun, Sep 29, 2024 at 03:16:21PM +0800, shejialuo wrote: > > I'd also rename this to e.g. "symrefTargetIsNotAReference" or something > > like that, because it's not really about whether or not the referent is > > "escaping". It's a bit of a mouthful, but I don't really have a better > > name. So feel free to pick something different that describes the error > > better. > > > > I guess "symrefTargetIsNotAReference" is a little too long. If we decide > to convert it to error later. Why not just put it into the "badReferent" > fsck message? > > So, I do not think we need to rename. As I have talked about, we don't > need to map error case to fsck message id one by one.
Mostly because I disagree with this here. I think there should be a 1:1 mapping, and "badReferent" is too generic to provide that.
Patrick