Re: [PATCH 04/28] t/test-lib: introduce FULL_HEX
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- May 6, 2018, 23:53 UTC
- Message-ID
- <CAPig+cTrLseKxznrMb63rQ4NK1JYvPraV=Bz6vbnO0sY6qkK=Q@mail.gmail.com>
- In-Reply-To
- <20180506231752.975110-5-sandals@crustytoothpaste.net>
On Sun, May 6, 2018 at 7:17 PM, brian m. carlson <sandals@crustytoothpaste.net> wrote:
Show 6 quoted lines
> Currently we have a variable, $_x40, which contains a regex that matches > a full 40-character hex constant. However, with NewHash, we'll have > object IDs that are longer than 40 characters. In such a case, $_x40 > will be a confusing name. Create a $FULL_HEX variable which will always > reflect a regex matching the appropriate object ID, regardless of the > length of the current hash.
Bikeshedding: $FULL_HEX doesn't convey much. Perhaps $OID_REGEX? (And
$_x05 and $_x35 can be named $OID_REGEX_SHORT and
$OID_REGEX_{something}, respectively? Or perhaps they don't need
renaming?)> Signed-off-by: brian m. carlson <sandals@crustytoothpaste.net>