Re: [PATCH 04/28] t/test-lib: introduce FULL_HEX
- From
brian m. carlson <sandals@crustytoothpaste.net>
- Date
- May 7, 2018, 02:28 UTC
- Message-ID
- <20180507022801.GC953644@genre.crustytoothpaste.net>
- In-Reply-To
- <CAPig+cTrLseKxznrMb63rQ4NK1JYvPraV=Bz6vbnO0sY6qkK=Q@mail.gmail.com>
On Sun, May 06, 2018 at 07:53:42PM -0400, Eric Sunshine wrote:
Show 13 quoted lines
> On Sun, May 6, 2018 at 7:17 PM, brian m. carlson
> <sandals@crustytoothpaste.net> wrote:
> > Currently we have a variable, $_x40, which contains a regex that matches
> > a full 40-character hex constant. However, with NewHash, we'll have
> > object IDs that are longer than 40 characters. In such a case, $_x40
> > will be a confusing name. Create a $FULL_HEX variable which will always
> > reflect a regex matching the appropriate object ID, regardless of the
> > length of the current hash.
>
> Bikeshedding: $FULL_HEX doesn't convey much. Perhaps $OID_REGEX? (And
> $_x05 and $_x35 can be named $OID_REGEX_SHORT and
> $OID_REGEX_{something}, respectively? Or perhaps they don't need
> renaming?)I agree that $OID_REGEX is better. Thinking about it, I'm wondering if $_xoid might be shorter and familiar enough to people who are used to $_x40. I'll wait for other people to chime in, and then reroll.
I don't think the short forms will end up needing renaming, but I'll try to pick something sane in line with the others should that be necessary.
-- brian m. carlson: Houston, Texas, US OpenPGP: https://keybase.io/bk2204