From: Eric Sunshine Date: Sun, 06 May 2018 23:53:42 GMT Subject: Re: [PATCH 04/28] t/test-lib: introduce FULL_HEX Message-ID: In-Reply-To: <20180506231752.975110-5-sandals@crustytoothpaste.net> On Sun, May 6, 2018 at 7:17 PM, brian m. carlson wrote: > Currently we have a variable, $_x40, which contains a regex that matches > a full 40-character hex constant. However, with NewHash, we'll have > object IDs that are longer than 40 characters. In such a case, $_x40 > will be a confusing name. Create a $FULL_HEX variable which will always > reflect a regex matching the appropriate object ID, regardless of the > length of the current hash. Bikeshedding: $FULL_HEX doesn't convey much. Perhaps $OID_REGEX? (And $_x05 and $_x35 can be named $OID_REGEX_SHORT and $OID_REGEX_{something}, respectively? Or perhaps they don't need renaming?) > Signed-off-by: brian m. carlson