Show 10 quoted lines
> int run_auto_maintenance(int quiet)
> {
> struct child_process maint = CHILD_PROCESS_INIT;
> maint.git_cmd = 1;
>
> argv_array_pushl(&maint.args, "maintenance", "run", "--auto", NULL);
> if (quiet)
> argv_array_push(&maint.args, "--quiet");
> else
> argv_array_push(&maint.args, "--no-quiet");It's subjective, but this might be a good fit for the ternary operator:
argv_array_pushl(&maint.args, "maintenance", "run", "--auto", NULL);
argv_array_push(&maint.args, quiet ? "--quiet" : "--no-quiet");Or even:
argv_array_pushl(&maint.args, "maintenance", "run", "--auto",
quiet ? "--quiet" : "--no-quiet", NULL);The latter is a bit less readable to me.