From: Eric Sunshine Date: Thu, 30 Jul 2020 19:00:43 GMT Subject: Re: [PATCH v2 03/18] maintenance: replace run_auto_gc() Message-ID: In-Reply-To: <5757360f-a9e5-0bd2-b933-7efddee29cf6@gmail.com> On Thu, Jul 30, 2020 at 9:31 AM Derrick Stolee wrote: > int run_auto_maintenance(int quiet) > { > struct child_process maint = CHILD_PROCESS_INIT; > maint.git_cmd = 1; > > argv_array_pushl(&maint.args, "maintenance", "run", "--auto", NULL); > if (quiet) > argv_array_push(&maint.args, "--quiet"); > else > argv_array_push(&maint.args, "--no-quiet"); It's subjective, but this might be a good fit for the ternary operator: argv_array_pushl(&maint.args, "maintenance", "run", "--auto", NULL); argv_array_push(&maint.args, quiet ? "--quiet" : "--no-quiet"); Or even: argv_array_pushl(&maint.args, "maintenance", "run", "--auto", quiet ? "--quiet" : "--no-quiet", NULL); The latter is a bit less readable to me.