Re: [PATCH v4 01/12] pkt-line: extract set_packet_header()
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 5, 2016, 17:41 UTC
- Message-ID
- <CAPc5daV3Tke4qHjtpri=6QCRaOax_K3uYhpFzRcd271=GHj1+Q@mail.gmail.com>
- In-Reply-To
- <02E1DAD2-8CE7-4A5C-AD28-9E08F2414BDF@gmail.com>
On Fri, Aug 5, 2016 at 10:31 AM, Lars Schneider <larsxschneider@gmail.com> wrote:
Show 11 quoted lines
> >> On 04 Aug 2016, at 18:14, Junio C Hamano <gitster@pobox.com> wrote: >> >> signature would look more like write(2) and deserve to be called >> packet_write() but unfortunately the name is taken by what should >> have called packet_fmt() or something, but that squats on a good >> name packet_write(). Sigh. > > "Sigh" means, a series preparation patch that renames "packet_write()" > to "paket_write_fmt()" would not be a good idea? It is used 59 times > currently...
It would be a good idea in the longer term, I would think. I just wasn't sure if you are willing to volunteer, and in-flight topics will tolerate, such a change right now. I have a feeling that all the current callsites are fairly stable and no in-flight topic touches them, so if you feel like doing so, please go ahead ;-)