Re: [PATCH v4 08/19] parse-option: rename parse_opt_with_commit()
On Mon, Jun 22, 2015 at 9:57 PM, Junio C Hamano <gitster@pobox.com> wrote:
Show 16 quoted lines
> On Mon, Jun 22, 2015 at 8:38 AM, Karthik Nayak <karthik.188@gmail.com> wrote:
>> On Mon, Jun 22, 2015 at 6:34 AM, Junio C Hamano <gitster@pobox.com> wrote:
>>> On Sun, Jun 21, 2015 at 1:48 PM, Karthik Nayak <karthik.188@gmail.com> wrote:
>>>> Rename parse_opt_with_commit() to parse_opt_commit_object_name()
>>>> to show that it can be used to obtain a list of commits and is
>>>> not constricted to usage of '--contains' option.
>>>
>>> I think that is a brilliant idea, but unlike the other function you
>>> added earlier
>>> that can do only one object and adopts "last one wins" rule, this is cumulative,
>>> and that fact should be made clear to the developers in some way, no?
>>
>> Will add a comment
>
> I didn't mean that. Can't we indicate this with plural somewhere in the name?
> parse_opt_commits(), parse_opt_commit_into_list(), etc.?
--
Regards,
Karthik Nayak