Re: [PATCH v3 00/23] Kill the_index part 4
- From
Stefan Beller <sbeller@google.com>
- Date
- Sep 10, 2018, 18:35 UTC
- Message-ID
- <CAGZ79kYiD5kRP5WaqYpxFBnXdP=c4bK3cumH=OBC6_ud0o1OnA@mail.gmail.com>
- In-Reply-To
- <20180909085418.31531-1-pclouds@gmail.com>
On Sun, Sep 9, 2018 at 1:54 AM Nguyễn Thái Ngọc Duy <pclouds@gmail.com> wrote:
> > The last patch 24/24 has been merged into individual patches to add > repo_ prefix and avoid breaking in-flight topics. "repo" argument is > also moved up in rerere(), diff_setup() and init_revisions().
yay! So eventually we'd want to rename back to short names or we just postpone that decision if we want that in the future?
Show 23 quoted lines
> diff --git a/Documentation/technical/api-revision-walking.txt b/Documentation/technical/api-revision-walking.txt > index 55b878ade8..83e62533a0 100644 > --- a/Documentation/technical/api-revision-walking.txt > +++ b/Documentation/technical/api-revision-walking.txt > @@ -15,7 +15,7 @@ revision list. > Functions > --------- > > -`init_revisions`:: > +`repo_init_revisions`:: > > Initialize a rev_info structure with default values. The second > parameter may be NULL or can be prefix path, and then the `.prefix` > diff --git a/bisect.c b/bisect.c > index 560493acd2..6ae5e5b49e 100644 > --- a/bisect.c > +++ b/bisect.c > @@ -632,7 +632,7 @@ static void bisect_rev_setup(struct rev_info *revs, const char *prefix, > struct argv_array rev_argv = ARGV_ARRAY_INIT; > int i; > > - repo_init_revisions(revs, the_repository, prefix); > + repo_init_revisions(the_repository, revs, prefix);
Apparently I did not communicate clearly enough on the last round, Please note that the documentation is wrong with these patches applied:
`repo_init_revisions`::
[...] The second
parameter may be NULL or can be prefix path, and then the `.prefix`but the prefix parameter is the _third_ parameter in either order.