git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: ab/i18n

From
Junio C Hamano <gitster@pobox.com>
Date
Feb 24, 2011, 19:11 UTC
Message-ID
<7vfwrd1c3m.fsf@alter.siamese.dyndns.org>
In-Reply-To
<20110224102712.GC14115@elie>
Jonathan Nieder <jrnieder@gmail.com> writes:
> * The series is too long to read in one sitting.
>
>   Suggested fix: deal with some arbitrary early subset (35 patches?
>   I'd even prefer around 20) first.

Let's concentrate on making sure that the first four (i18n foundation, no markings) gets merged to 'master' first, using the early ones (say, "init", "clone", "add" and "branch") as a sanity checks.

And then we can stagger the remainder, perhaps at most 10 in one batch but preferrably smaller, two to three batches a week merged to 'next' and then down to 'master', over a few weeks.

Show 5 quoted lines
> * Patch 2 (add GETTEXT_POISON) is conceptually complicated since
>   its arbitrary string is not arbitrary.
>
>   Suggested fix: split it into two patches.  But I am still not sure
>   if that's considered acceptable?
See bottom.
> * Patch 2 squats on a valuable use_poison() identifier space.
>
>   Suggested fix: rename it to gettext_poison().

For this, I can just "rebase -i"; I don't think there is anything controversial nor tricky.

Show 6 quoted lines
> * Patches 5 (i18n: git-init basic messages) and onward do not
>   explain "we are marking strings for translation, in
>   preparation for translating them later" in their commit messages.
>
>   Suggested fix: use titles like «i18n: mark some "git init" messages
>   for translation».  Or ignore the problem --- it's not a big deal.

If you want to see a mixed patch that has both logic reorganization and message marking in one change, e.g. i18n: git-revert split up "could not revert/apply" message, split into one that only reorganizes the code structure and the other that only marks literal string, your "mark for translation" would start making sense. The other half won't even have "i18n:" prefix in that case. If we go that route, it would be better to have the code restructuring patches merged to 'master' before (and independent from) i18n. But the ones I took a look at didn't seem too bad (e.g. i18n: git-revert "Your local changes" message). I think Ævar did a good job splitting the changes into a reasonably small bite-sized chunks in this round.

Assuming that we are not going to do that "even finer" split, I think the patches we have on 'pu' are descriptive enough already. They look like this:

    i18n: git-tag tag_template message
    i18n: git-mv "bad" messages
> Does that sound like a fair summary?
To me it does.  Thanks.
> I'd be happy to reroll the first 30 or so patches following whatever
> approach is the consensus for these things to move this forward.

I tend to think that except for the GETTEXT_POISON bit what we have is mostly fine.

Can you give two weather-balloon counterproposal patches for "add GETTEXT_POISON" and "i18n: git-status "Changes to be committed" message" to illustrate what you have in mind, and perhaps list the patches in Ævar's series that need similar changes as you would need for the latter, to illustrate the extent of damage a careless translator can cause by omitting '#' from the beginning? Would that help the topic get unstuck?

Previous: Jonathan NiederNext: Ævar Arnfjörð Bjarmason
Message 14 of 46 in “What's cooking in git.git (Feb 2011, #05; Wed, 23)”
  1. Junio C HamanoFeb 23, 2011
  2. ab/i18n (What's cooking in git.git (Feb 2011, #05; Wed, 23))Jonathan Nieder, Feb 23, 2011
  3. Junio C HamanoFeb 24, 2011
  4. Ævar Arnfjörð BjarmasonFeb 24, 2011
  5. Jonathan NiederFeb 24, 2011
  6. Ævar Arnfjörð BjarmasonFeb 24, 2011
  7. Jonathan NiederFeb 24, 2011
  8. Jonathan NiederFeb 24, 2011
  9. Ævar Arnfjörð BjarmasonFeb 25, 2011
  10. Jonathan NiederFeb 26, 2011
  11. Jonathan NiederFeb 24, 2011
  12. Erik Faye-LundFeb 24, 2011
  13. Jonathan NiederFeb 24, 2011
  14. Junio C HamanoFeb 24, 2011
  15. Ævar Arnfjörð BjarmasonFeb 24, 2011
  16. Johan HerlandFeb 23, 2011
  17. Junio C HamanoFeb 24, 2011
  18. Johan HerlandFeb 24, 2011
  19. Ævar Arnfjörð BjarmasonFeb 24, 2011
  20. Junio C HamanoFeb 24, 2011
  21. Ævar Arnfjörð BjarmasonFeb 24, 2011
  22. Junio C HamanoFeb 24, 2011
  23. Ævar Arnfjörð BjarmasonFeb 24, 2011
  24. Erik Faye-LundFeb 24, 2011
  25. Ævar Arnfjörð BjarmasonFeb 24, 2011
  26. Jonathan NiederFeb 24, 2011
  27. Johannes SchindelinFeb 25, 2011
  28. Kirill SmelkovFeb 25, 2011
  29. Johannes SchindelinFeb 25, 2011
  30. Kirill SmelkovFeb 25, 2011
  31. Johannes SchindelinFeb 25, 2011
  32. Kirill SmelkovFeb 26, 2011
  33. Kirill SmelkovFeb 26, 2011
  34. cross-compiling msys-1.0.dll, was Re: What's cooking in git.git (Feb 2011, #05; Wed, 23)Johannes Schindelin, Feb 26, 2011
  35. Kirill SmelkovMar 12, 2011
  36. Johannes SchindelinMar 12, 2011
  37. Johannes SchindelinFeb 27, 2011
  38. Kirill SmelkovMar 12, 2011
  39. Adding Beyond Compare as a merge tool, was: Re: What's cooking in git.git (Feb 2011, #05; Wed, 23)Sebastian Schuberth, Feb 26, 2011
  40. Junio C HamanoFeb 26, 2011
  41. Sebastian SchuberthFeb 26, 2011
  42. Chris PackhamFeb 27, 2011
  43. Junio C HamanoFeb 27, 2011
  44. Sebastian SchuberthFeb 27, 2011
  45. Sebastian SchuberthFeb 27, 2011
  46. Sebastian SchuberthFeb 27, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.