Re: ab/i18n
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Feb 24, 2011, 10:27 UTC
- Message-ID
- <20110224102712.GC14115@elie>
- In-Reply-To
- <AANLkTimn_CmWORwJfWXEiY18QCmXdNZMhCUC9YBMo_kV@mail.gmail.com>
Erik Faye-Lund wrote:
> I like the idea, but perhaps we could auto-generate a Pig Latin > translation or something instead?
Sorry for the fuss. If I understand correctly, the remaining issues with the current ab/i18n branch in 'pu' are:
* The series is too long to read in one sitting.
Suggested fix: deal with some arbitrary early subset (35 patches? I'd even prefer around 20) first.
* Patch 2 (add GETTEXT_POISON) is conceptually complicated since its arbitrary string is not arbitrary.
Suggested fix: split it into two patches. But I am still not sure if that's considered acceptable?
* Patch 2 squats on a valuable use_poison() identifier space.
Suggested fix: rename it to gettext_poison().
* Patches 5 (i18n: git-init basic messages) and onward do not explain "we are marking strings for translation, in preparation for translating them later" in their commit messages.
Suggested fix: use titles like «i18n: mark some "git init" messages for translation». Or ignore the problem --- it's not a big deal.
* We haven't run an automated tool to check that this is a no-op in the -UGETTEXT_POISON case.
Suggested fix: build without debugging symbols and compare the binaries. Or invent a tool to check patches. Or just use our eyes, like we always have.
Does that sound like a fair summary? I'd be happy to reroll the first 30 or so patches following whatever approach is the consensus for these things to move this forward.