Re: [WIP/PATCH v5 03/10] for-each-ref: rename 'refinfo' to 'ref_array_item'
On 06/08/2015 08:12 PM, Matthieu Moy wrote:
Show 8 quoted lines
> Karthik Nayak <karthik.188@gmail.com> writes:
>
>> Make 'symref' a non const char pointer, so that the compiler doesn't
>> throw an error when we try to free the memory allocated to it.
>
> Casting to non-cost when calling free() is a common pattern. I think it
> would make more sense to cast at free() time and keep the member const.
>
Ok! will do that. thanks :)
--
Regards,
Karthik