git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [WIP/PATCH v5 05/10] for-each-ref: introduce 'ref_array_clear()'

From
Karthik Nayak <karthik.188@gmail.com>
Date
Jun 8, 2015, 20:19 UTC
Message-ID
<5575F8CB.8080009@gmail.com>
In-Reply-To
<vpqa8wat8u9.fsf@anie.imag.fr>
On 06/08/2015 10:51 PM, Matthieu Moy wrote:
Show 27 quoted lines
> Junio C Hamano <gitster@pobox.com> writes:
>
>> Matthieu Moy <Matthieu.Moy@grenoble-inp.fr> writes:
>>
>>> Karthik Nayak <karthik.188@gmail.com> writes:
>>>
>>>> On 06/08/2015 08:23 PM, Matthieu Moy wrote:
>>>>> Karthik Nayak <karthik.188@gmail.com> writes:
>>>>>
>>>>>> +/* Free all memory allocated for ref_array */
>>>>>> +void ref_array_clear(struct ref_array *array)
>>>>>
>>>>> Is this a private function? If so, then add static. If not, you probably
>>>>> want to export it in a .h file.
>>>>>
>>>> It is in ref-filter.h.
>>>
>>> Ah, OK. It comes later in the series.
>>
>> Confused I am; if it comes later not in the same patch then it is
>> not OK, is it?
>
> We could introduce ref-filter.h earlier, indeed. To me, the current
> solution is good enough, but introducing ref-filter.h early and adding
> function definition there in the same commit as you drop the "static"
> keyword for them would clearly be an improvement.
>

But that would break the flow, wouldn't it? I wanted ref-filter to be introduced together, hence right after ref-filter.h we move code to ref-filter.c

-- 
Regards,
Karthik
Previous: Matthieu MoyNext: Matthieu Moy
Message 18 of 27 in “create ref-filter from for-each-ref”
  1. 0/10 create ref-filter from for-each-refKarthik Nayak, Jun 6, 2015
  2. 01/10 for-each-ref: extract helper functions out of grab_single_ref()Karthik Nayak, Jun 6, 2015
  3. 02/10 for-each-ref: clean up codeKarthik Nayak, Jun 6, 2015
  4. Matthieu MoyJun 8, 2015
  5. Karthik NayakJun 8, 2015
  6. Matthieu MoyJun 8, 2015
  7. 03/10 for-each-ref: rename 'refinfo' to 'ref_array_item'Karthik Nayak, Jun 6, 2015
  8. Matthieu MoyJun 8, 2015
  9. Karthik NayakJun 8, 2015
  10. 04/10 for-each-ref: introduce new structures for better organisationKarthik Nayak, Jun 6, 2015
  11. 05/10 for-each-ref: introduce 'ref_array_clear()'Karthik Nayak, Jun 6, 2015
  12. Matthieu MoyJun 8, 2015
  13. Karthik NayakJun 8, 2015
  14. Karthik NayakJun 8, 2015
  15. Matthieu MoyJun 8, 2015
  16. Junio C HamanoJun 8, 2015
  17. Matthieu MoyJun 8, 2015
  18. Karthik NayakJun 8, 2015
  19. Matthieu MoyJun 9, 2015
  20. 06/10 for-each-ref: rename some functions and make them publicKarthik Nayak, Jun 6, 2015
  21. 07/10 ref-filter: add 'ref-filter.h'Karthik Nayak, Jun 6, 2015
  22. 08/10 ref-filter: move code from 'for-each-ref'Karthik Nayak, Jun 6, 2015
  23. 09/10 for-each-ref: introduce filter_refs()Karthik Nayak, Jun 6, 2015
  24. 10/10 ref-filter: make 'ref_array_item' use a FLEX_ARRAY for refnameKarthik Nayak, Jun 6, 2015
  25. Christian CouderJun 6, 2015
  26. Karthik NayakJun 6, 2015
  27. Karthik NayakJun 6, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.