git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [WIP/PATCH v5 02/10] for-each-ref: clean up code

From
Matthieu Moy <matthieu.moy@grenoble-inp.fr>
Date
Jun 8, 2015, 14:37 UTC
Message-ID
<vpqd2168dwa.fsf@anie.imag.fr>
In-Reply-To
<1433574581-23980-2-git-send-email-karthik.188@gmail.com>
Karthik Nayak <karthik.188@gmail.com> writes:
Show 5 quoted lines
> In 'grab_single_ref()' remove the extra count variable 'cnt' and
> use the variable 'grab_cnt' of structure 'grab_ref_cbdata' directly
> instead.
>
> Change comment in 'struct ref_sort' to reflect changes in code.
I don't see how the comment change is related to the code change:
Show 27 quoted lines
>  struct ref_sort {
>  	struct ref_sort *next;
> -	int atom; /* index into used_atom array */
> +	int atom; /* index into 'struct atom_value *' array */
>  	unsigned reverse : 1;
>  };
>  
> @@ -881,7 +881,6 @@ static int grab_single_ref(const char *refname, const unsigned char *sha1, int f
>  {
>  	struct grab_ref_cbdata *cb = cb_data;
>  	struct refinfo *ref;
> -	int cnt;
>  
>  	if (flag & REF_BAD_NAME) {
>  		  warning("ignoring ref with broken name %s", refname);
> @@ -898,10 +897,8 @@ static int grab_single_ref(const char *refname, const unsigned char *sha1, int f
>  	 */
>  	ref = new_refinfo(refname, sha1, flag);
>  
> -	cnt = cb->grab_cnt;
> -	REALLOC_ARRAY(cb->grab_array, cnt + 1);
> -	cb->grab_array[cnt++] = ref;
> -	cb->grab_cnt = cnt;
> +	REALLOC_ARRAY(cb->grab_array, cb->grab_cnt + 1);
> +	cb->grab_array[cb->grab_cnt++] = ref;
>  	return 0;
>  }
Did you squash the comment change into the wrong commit?
-- 
Matthieu Moy
http://www-verimag.imag.fr/~moy/
Previous: Karthik NayakNext: Karthik Nayak
Message 4 of 27 in “create ref-filter from for-each-ref”
  1. 0/10 create ref-filter from for-each-refKarthik Nayak, Jun 6, 2015
  2. 01/10 for-each-ref: extract helper functions out of grab_single_ref()Karthik Nayak, Jun 6, 2015
  3. 02/10 for-each-ref: clean up codeKarthik Nayak, Jun 6, 2015
  4. Matthieu MoyJun 8, 2015
  5. Karthik NayakJun 8, 2015
  6. Matthieu MoyJun 8, 2015
  7. 03/10 for-each-ref: rename 'refinfo' to 'ref_array_item'Karthik Nayak, Jun 6, 2015
  8. Matthieu MoyJun 8, 2015
  9. Karthik NayakJun 8, 2015
  10. 04/10 for-each-ref: introduce new structures for better organisationKarthik Nayak, Jun 6, 2015
  11. 05/10 for-each-ref: introduce 'ref_array_clear()'Karthik Nayak, Jun 6, 2015
  12. Matthieu MoyJun 8, 2015
  13. Karthik NayakJun 8, 2015
  14. Karthik NayakJun 8, 2015
  15. Matthieu MoyJun 8, 2015
  16. Junio C HamanoJun 8, 2015
  17. Matthieu MoyJun 8, 2015
  18. Karthik NayakJun 8, 2015
  19. Matthieu MoyJun 9, 2015
  20. 06/10 for-each-ref: rename some functions and make them publicKarthik Nayak, Jun 6, 2015
  21. 07/10 ref-filter: add 'ref-filter.h'Karthik Nayak, Jun 6, 2015
  22. 08/10 ref-filter: move code from 'for-each-ref'Karthik Nayak, Jun 6, 2015
  23. 09/10 for-each-ref: introduce filter_refs()Karthik Nayak, Jun 6, 2015
  24. 10/10 ref-filter: make 'ref_array_item' use a FLEX_ARRAY for refnameKarthik Nayak, Jun 6, 2015
  25. Christian CouderJun 6, 2015
  26. Karthik NayakJun 6, 2015
  27. Karthik NayakJun 6, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.