From: Karthik Nayak Date: Mon, 08 Jun 2015 15:19:18 GMT Subject: Re: [WIP/PATCH v5 03/10] for-each-ref: rename 'refinfo' to 'ref_array_item' Message-ID: <5575B276.7030005@gmail.com> In-Reply-To: On 06/08/2015 08:12 PM, Matthieu Moy wrote: > Karthik Nayak writes: > >> Make 'symref' a non const char pointer, so that the compiler doesn't >> throw an error when we try to free the memory allocated to it. > > Casting to non-cost when calling free() is a common pattern. I think it > would make more sense to cast at free() time and keep the member const. > Ok! will do that. thanks :) -- Regards, Karthik