git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [WIP/PATCH v5 02/10] for-each-ref: clean up code

From
Matthieu Moy <matthieu.moy@grenoble-inp.fr>
Date
Jun 8, 2015, 16:23 UTC
Message-ID
<vpqfv622mpd.fsf@anie.imag.fr>
In-Reply-To
<5575B30B.6000407@gmail.com>
Karthik Nayak <karthik.188@gmail.com> writes:
> I put these two together as they are trivial changes.
> Either I could reword the commit message or split the commit.

I'd split the commit. Actually, even though it's only a small comment change, it's not so "trivial" in the sense that one needs a good understanding of the code to check the correctness of your patch.

-- 
Matthieu Moy
http://www-verimag.imag.fr/~moy/
Previous: Karthik NayakNext: Karthik Nayak
Message 6 of 27 in “create ref-filter from for-each-ref”
  1. 0/10 create ref-filter from for-each-refKarthik Nayak, Jun 6, 2015
  2. 01/10 for-each-ref: extract helper functions out of grab_single_ref()Karthik Nayak, Jun 6, 2015
  3. 02/10 for-each-ref: clean up codeKarthik Nayak, Jun 6, 2015
  4. Matthieu MoyJun 8, 2015
  5. Karthik NayakJun 8, 2015
  6. Matthieu MoyJun 8, 2015
  7. 03/10 for-each-ref: rename 'refinfo' to 'ref_array_item'Karthik Nayak, Jun 6, 2015
  8. Matthieu MoyJun 8, 2015
  9. Karthik NayakJun 8, 2015
  10. 04/10 for-each-ref: introduce new structures for better organisationKarthik Nayak, Jun 6, 2015
  11. 05/10 for-each-ref: introduce 'ref_array_clear()'Karthik Nayak, Jun 6, 2015
  12. Matthieu MoyJun 8, 2015
  13. Karthik NayakJun 8, 2015
  14. Karthik NayakJun 8, 2015
  15. Matthieu MoyJun 8, 2015
  16. Junio C HamanoJun 8, 2015
  17. Matthieu MoyJun 8, 2015
  18. Karthik NayakJun 8, 2015
  19. Matthieu MoyJun 9, 2015
  20. 06/10 for-each-ref: rename some functions and make them publicKarthik Nayak, Jun 6, 2015
  21. 07/10 ref-filter: add 'ref-filter.h'Karthik Nayak, Jun 6, 2015
  22. 08/10 ref-filter: move code from 'for-each-ref'Karthik Nayak, Jun 6, 2015
  23. 09/10 for-each-ref: introduce filter_refs()Karthik Nayak, Jun 6, 2015
  24. 10/10 ref-filter: make 'ref_array_item' use a FLEX_ARRAY for refnameKarthik Nayak, Jun 6, 2015
  25. Christian CouderJun 6, 2015
  26. Karthik NayakJun 6, 2015
  27. Karthik NayakJun 6, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.