Re: [PATCH v4 3/6] unit-tests: add if_test
- From
René Scharfe <l.s.r@web.de>
- Date
- Aug 1, 2024, 07:32 UTC
- Message-ID
- <51ec32ed-f2f1-4993-92e5-1acfcdbb7c79@web.de>
- In-Reply-To
- <CAO_smVh_2FEbTAqJDMZAKMsfTKrB=NH36G6jNmMTaEOtRaP2Pg@mail.gmail.com>
Am 01.08.24 um 00:04 schrieb Kyle Lippincott:
Show 9 quoted lines
> > I'm still not wild about the name, and I'm still not convinced of the > readability improvements. I still want to read `if_test(...)` as > having a condition in the parenthesis. Tests "skipping everything" > seems like an internal implementation detail that there's disagreement > on whether to expose to the test author/reader or not; maybe we should > redesign if we don't migrate to clar or some other test framework. Do > we get significant benefits from a test function continuing to execute > after the "skip everything" flag has been set?
The idea is that the unit test framework may allow to skip individual tests in the future; see https://lore.kernel.org/git/c2de7f4e-e5dc-4324-8238-1d06795a2107@gmail.com/
René