From: René Scharfe Date: Thu, 01 Aug 2024 07:32:33 GMT Subject: Re: [PATCH v4 3/6] unit-tests: add if_test Message-ID: <51ec32ed-f2f1-4993-92e5-1acfcdbb7c79@web.de> In-Reply-To: Am 01.08.24 um 00:04 schrieb Kyle Lippincott: > > I'm still not wild about the name, and I'm still not convinced of the > readability improvements. I still want to read `if_test(...)` as > having a condition in the parenthesis. Tests "skipping everything" > seems like an internal implementation detail that there's disagreement > on whether to expose to the test author/reader or not; maybe we should > redesign if we don't migrate to clar or some other test framework. Do > we get significant benefits from a test function continuing to execute > after the "skip everything" flag has been set? The idea is that the unit test framework may allow to skip individual tests in the future; see https://lore.kernel.org/git/c2de7f4e-e5dc-4324-8238-1d06795a2107@gmail.com/ René