Re: [PATCH v2 24/25] register_ref(): make a copy of the bad reference SHA-1
- From
Michael Haggerty <mhagger@alum.mit.edu>
- Date
- May 30, 2013, 21:51 UTC
- Message-ID
- <51A7C9E8.10108@alum.mit.edu>
- In-Reply-To
- <7vk3mhviaw.fsf@alter.siamese.dyndns.org>
On 05/29/2013 06:53 PM, Junio C Hamano wrote:
Show 6 quoted lines
> Michael Haggerty <mhagger@alum.mit.edu> writes: >> [...] >> + current_bad_sha1 = xmalloc(20); >> + hashcpy(current_bad_sha1, sha1); > > This, together with 18/25, may hint that we want hashdup()?
I thought about it, but was surprised that I could only find one or two other places in the existing code that would use such a function. But sure, I would be happy to submit a patch.
I think hashdup() needn't be inline, so the definition can't go with its cousins in cache.h. There is no cache.c. So where would be the best place to define hashdup()? object.c? sha1_name.c?
While I'm at it, I think it would be nice to have constants like
#define SHA1_LEN 20 #define SHA1_HEX_LEN 40
and start using those instead of magic numbers. Any objections (or suggestions for better names)?
Michael
-- Michael Haggerty mhagger@alum.mit.edu http://softwareswirl.blogspot.com/