git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 3/3] rev-list --min-parents,--max-parents: doc and test and completion

From
Michael J Gruber <git@drmicha.warpmail.net>
Date
Mar 21, 2011, 14:56 UTC
Message-ID
<4D876714.8040604@drmicha.warpmail.net>
In-Reply-To
<7vbp14ttgu.fsf@alter.siamese.dyndns.org>
Junio C Hamano venit, vidit, dixit 21.03.2011 15:54:
Show 10 quoted lines
> Michael J Gruber <git@drmicha.warpmail.net> writes:
> 
>> Jeff King venit, vidit, dixit 21.03.2011 11:54:
>>> On Mon, Mar 21, 2011 at 10:01:53AM +0100, Michael J Gruber wrote:
>>>
>> In my community it is very common, which may partly be due to the fact
>> that there is a strong proportion of non-native speakers. It took it for
>> granted that it's a standard expression.
> 
> Perhaps in math circles or something?
Yeah, those (us) weirdos ;)
Show 45 quoted lines
> 
>>> I really think "Show only commits which have at least (or at most,
>>> respectively) that many commits" says the same thing, but is way more
>>> accessible.
>>
>> Sounds good, I'm happy with that. Resend or squash on apply?
> 
> The "... A resp. B" composition did made me go "huh?", even though I
> managed to guess what you meant; I agree Jeff's rewrite is much more
> approacheable.
> 
> The code part of the patch needs a bit of touch-up anyway, so let's do a
> v2.
> 
> It is not like you will have a million copies of "struct rev_info", while
> you will be reading from and comparing with the field for each commit
> during the traversal, so I'd rather see these max/min stored in the usual
> "int", not squashed into bitfields.  Also initialize max to the magic
> token that means "unlimited" in init_revisions() without swapping the
> meaning of comparison.  One initialization assignment you can omit there
> is not worth the resulting confusion.
> 
>>>>> That way it is obvious that "--merges" cancels a previous --min-parents
>>>>> on the command line (maybe the text should be "this is an alias for..."
>>>>> to make it clear that doing it is exactly the same).
>>>>
>>>> Yes, that is helpful. I have doubts about "alias" for. Without wanting
>>>> to sound elitist or something, I have the impression that we start
>>>> catering for users who understand "equivalent" more reliably than "alias".
>>>
>>> I just wanted to make sure people didn't think "equivalent" meant "has a
>>> similar effect to" as opposed to "is exactly as if you did". But reading
>>> it again, I think "equivalent" is fine, and I see you picked it up in
>>> the latest series.
>>
>> I may be wrong about what is common in this case, too. For me, "alias"
>> is foremost a technical term, and I would guess that many non-native
>> speaker know "alias" either in the technical sense or not at all, but
>> not so much in the common English sense. But either way is fine.
> 
> We would want to make sure the reader understands that saying --no-merges
> is _exactly the same_ (your words above) as saying --max-parents=1, so why
> not spell that out, i.e. "This is exactly the same as `--max-parents=1`"?
> 
> Thanks.

I guess you haven't seen v2 yet, where most of these changes are incorporated.

For the doc, "exactly the same" is clean and simple and understandable for both Jeff and myself, I guess ;)

Michael
Previous: Junio C HamanoNext: Junio C Hamano
Message 59 of 67 in “revision.c: --merges, --no-merges and --merges-only”
  1. 0/2 revision.c: --merges, --no-merges and --merges-onlyMichael J Gruber, Mar 17, 2011
  2. 1/2 revision.c: rename --merges to --merges-onlyMichael J Gruber, Mar 17, 2011
  3. 2/2 revision.c: introduce --merges to undo --no-mergesMichael J Gruber, Mar 17, 2011
  4. Junio C HamanoMar 17, 2011
  5. Jeff KingMar 17, 2011
  6. Michael J GruberMar 18, 2011
  7. Junio C HamanoMar 18, 2011
  8. Michael J GruberMar 18, 2011
  9. Jeff KingMar 18, 2011
  10. 0/3 rev-list and friends: --min-parents, --max-parentsMichael J Gruber, Mar 18, 2011
  11. Michael J GruberMar 18, 2011
  12. Jeff KingMar 18, 2011
  13. Michael J GruberMar 21, 2011
  14. 0/3 rev-list and friends: --min-parents, --max-parentsMichael J Gruber, Mar 21, 2011
  15. Jeff KingMar 21, 2011
  16. 0/5 rev-list and friends: --min-parents, --max-parentsMichael J Gruber, Mar 23, 2011
  17. Jeff KingMar 23, 2011
  18. Junio C HamanoMar 23, 2011
  19. Junio C HamanoMar 23, 2011
  20. Jonathan NiederMar 24, 2011
  21. Michael J GruberMar 24, 2011
  22. Jonathan NiederMar 24, 2011
  23. 0/2 test_when_finished and returning earlyJonathan Nieder, Aug 8, 2011
  24. 1/2 test: simplify return value of test_run_Jonathan Nieder, Aug 8, 2011
  25. 2/2 test: cope better with use of return for errorsJonathan Nieder, Aug 8, 2011
  26. Johannes SixtAug 9, 2011
  27. Jeff KingAug 9, 2011
  28. t3900: do not reference numbered arguments from the test scriptJohannes Sixt, Aug 11, 2011
  29. Jonathan NiederAug 11, 2011
  30. Junio C HamanoAug 11, 2011
  31. Jeff KingAug 8, 2011
  32. 1/5 t6009: use test_commit() from test-lib.shMichael J Gruber, Mar 23, 2011
  33. 2/5 revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 23, 2011
  34. 3/5 squash! revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 23, 2011
  35. 4/5 rev-list --min-parents,--max-parents: doc, test and completionMichael J Gruber, Mar 23, 2011
  36. 5/5 fixup! rev-list --min-parents,--max-parents: doc, test and completionMichael J Gruber, Mar 23, 2011
  37. 1/3 t6009: use test_commit() from test-lib.shMichael J Gruber, Mar 21, 2011
  38. 2/3 revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 21, 2011
  39. Michael J GruberMar 21, 2011
  40. Junio C HamanoMar 21, 2011
  41. Jonathan NiederMar 21, 2011
  42. 3/3 rev-list --min-parents,--max-parents: doc and test and completionMichael J Gruber, Mar 21, 2011
  43. Jonathan NiederMar 21, 2011
  44. Michael J GruberMar 22, 2011
  45. Jonathan NiederMar 23, 2011
  46. 1/3 revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 18, 2011
  47. Jeff KingMar 18, 2011
  48. Michael J GruberMar 21, 2011
  49. Jonathan NiederMar 18, 2011
  50. Junio C HamanoMar 18, 2011
  51. Michael J GruberMar 21, 2011
  52. 2/3 t6009: use test_commit() from test-lib.shMichael J Gruber, Mar 18, 2011
  53. 3/3 rev-list --min-parents,--max-parents: doc and test and completionMichael J Gruber, Mar 18, 2011
  54. Jeff KingMar 18, 2011
  55. Michael J GruberMar 21, 2011
  56. Jeff KingMar 21, 2011
  57. Michael J GruberMar 21, 2011
  58. Junio C HamanoMar 21, 2011
  59. Michael J GruberMar 21, 2011
  60. Junio C HamanoMar 21, 2011
  61. Jonathan NiederMar 18, 2011
  62. Michael J GruberMar 21, 2011
  63. Jonathan NiederMar 21, 2011
  64. Michael J GruberMar 22, 2011
  65. Jeff KingMar 18, 2011
  66. Michael J GruberMar 18, 2011
  67. Jeff KingMar 18, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.