git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH/RFD 0/2] revision.c: --merges, --no-merges and --merges-only

From
Jeff King <peff@peff.net>
Date
Mar 18, 2011, 08:56 UTC
Message-ID
<20110318085616.GA16703@sigill.intra.peff.net>
In-Reply-To
<7vbp18yh1f.fsf@alter.siamese.dyndns.org>
On Fri, Mar 18, 2011 at 01:22:20AM -0700, Junio C Hamano wrote:
Show 14 quoted lines
> Michael J Gruber <git@drmicha.warpmail.net> writes:
> 
> > From the ui perspective I'm somehow not a big fan of tri-state options
> > but can't give hard reasons why; maybe because they force you to use
> > option arguments.
> 
> But in this particular case, you cannot really hack it with two options
> that appear independent on surface but in reality are not. Logically, it
> is an enum <everything, non-merges, merges-only> and you can choose only
> one of them, and it is even worse from the UI perspective to use
> combination of two not-quite-independent options.
> 
> Also I have a hidden agenda to add "because we could" --show=octopus to
> the enum later perhaps only to my private edition ;-)

Yes, I read your other response to Michael and I think that makes the most sense. In the most general form it is "--show=<num_parents>", though I don't think there is really much point in values besides 0, 1, 2, or >2 (or combinations thereof, though again, probably only "this particular value" or "any" is of interest).

So what you have said so far covers that, except for "--show=roots", which I think would be a useful addition.

The over-engineer in me wants to have the general form "--grep-by-parent-count=0,1" and "--show=no-merges" as a human-friendly alias to that. But I can't think of a good reason to have the general form, except for the sake of generalizing.

-Peff
Previous: Michael J GruberNext: Michael J Gruber
Message 9 of 67 in “revision.c: --merges, --no-merges and --merges-only”
  1. 0/2 revision.c: --merges, --no-merges and --merges-onlyMichael J Gruber, Mar 17, 2011
  2. 1/2 revision.c: rename --merges to --merges-onlyMichael J Gruber, Mar 17, 2011
  3. 2/2 revision.c: introduce --merges to undo --no-mergesMichael J Gruber, Mar 17, 2011
  4. Junio C HamanoMar 17, 2011
  5. Jeff KingMar 17, 2011
  6. Michael J GruberMar 18, 2011
  7. Junio C HamanoMar 18, 2011
  8. Michael J GruberMar 18, 2011
  9. Jeff KingMar 18, 2011
  10. 0/3 rev-list and friends: --min-parents, --max-parentsMichael J Gruber, Mar 18, 2011
  11. Michael J GruberMar 18, 2011
  12. Jeff KingMar 18, 2011
  13. Michael J GruberMar 21, 2011
  14. 0/3 rev-list and friends: --min-parents, --max-parentsMichael J Gruber, Mar 21, 2011
  15. Jeff KingMar 21, 2011
  16. 0/5 rev-list and friends: --min-parents, --max-parentsMichael J Gruber, Mar 23, 2011
  17. Jeff KingMar 23, 2011
  18. Junio C HamanoMar 23, 2011
  19. Junio C HamanoMar 23, 2011
  20. Jonathan NiederMar 24, 2011
  21. Michael J GruberMar 24, 2011
  22. Jonathan NiederMar 24, 2011
  23. 0/2 test_when_finished and returning earlyJonathan Nieder, Aug 8, 2011
  24. 1/2 test: simplify return value of test_run_Jonathan Nieder, Aug 8, 2011
  25. 2/2 test: cope better with use of return for errorsJonathan Nieder, Aug 8, 2011
  26. Johannes SixtAug 9, 2011
  27. Jeff KingAug 9, 2011
  28. t3900: do not reference numbered arguments from the test scriptJohannes Sixt, Aug 11, 2011
  29. Jonathan NiederAug 11, 2011
  30. Junio C HamanoAug 11, 2011
  31. Jeff KingAug 8, 2011
  32. 1/5 t6009: use test_commit() from test-lib.shMichael J Gruber, Mar 23, 2011
  33. 2/5 revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 23, 2011
  34. 3/5 squash! revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 23, 2011
  35. 4/5 rev-list --min-parents,--max-parents: doc, test and completionMichael J Gruber, Mar 23, 2011
  36. 5/5 fixup! rev-list --min-parents,--max-parents: doc, test and completionMichael J Gruber, Mar 23, 2011
  37. 1/3 t6009: use test_commit() from test-lib.shMichael J Gruber, Mar 21, 2011
  38. 2/3 revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 21, 2011
  39. Michael J GruberMar 21, 2011
  40. Junio C HamanoMar 21, 2011
  41. Jonathan NiederMar 21, 2011
  42. 3/3 rev-list --min-parents,--max-parents: doc and test and completionMichael J Gruber, Mar 21, 2011
  43. Jonathan NiederMar 21, 2011
  44. Michael J GruberMar 22, 2011
  45. Jonathan NiederMar 23, 2011
  46. 1/3 revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 18, 2011
  47. Jeff KingMar 18, 2011
  48. Michael J GruberMar 21, 2011
  49. Jonathan NiederMar 18, 2011
  50. Junio C HamanoMar 18, 2011
  51. Michael J GruberMar 21, 2011
  52. 2/3 t6009: use test_commit() from test-lib.shMichael J Gruber, Mar 18, 2011
  53. 3/3 rev-list --min-parents,--max-parents: doc and test and completionMichael J Gruber, Mar 18, 2011
  54. Jeff KingMar 18, 2011
  55. Michael J GruberMar 21, 2011
  56. Jeff KingMar 21, 2011
  57. Michael J GruberMar 21, 2011
  58. Junio C HamanoMar 21, 2011
  59. Michael J GruberMar 21, 2011
  60. Junio C HamanoMar 21, 2011
  61. Jonathan NiederMar 18, 2011
  62. Michael J GruberMar 21, 2011
  63. Jonathan NiederMar 21, 2011
  64. Michael J GruberMar 22, 2011
  65. Jeff KingMar 18, 2011
  66. Michael J GruberMar 18, 2011
  67. Jeff KingMar 18, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.