git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH/RFD 0/2] revision.c: --merges, --no-merges and --merges-only

From
Michael J Gruber <git@drmicha.warpmail.net>
Date
Mar 18, 2011, 07:56 UTC
Message-ID
<4D831043.1060709@drmicha.warpmail.net>
In-Reply-To
<20110317195905.GG20508@sigill.intra.peff.net>
Jeff King venit, vidit, dixit 17.03.2011 20:59:
Show 12 quoted lines
> On Thu, Mar 17, 2011 at 12:33:56PM +0100, Michael J Gruber wrote:
> 
>> This mini series makes it so that --no-merges undoes --merges
>> and vice versa, as the user should be able to expect,
>> and that --merges-only is a separate option.
> 
> Having recently been confused by this (and frustrated at the lack of an
> equivalent to your new "--merges"), I do think the result is better.
> 
> However, this is totally changing the meaning of an option to plumbing
> like rev-list (among others). Is it worth the breakage? If so, what's
> the migration plan? Did I miss a discussion somewhere?
You missed only the "D" in RFD :)

The meaning of a plumbing option can't be changed light-heartedly, of course. OTOH, the current design is *really bad* from the ui point of view. The expectation that

"cmd --no-foo --foo" is eq. to "cmd --foo"
and
"cmd --foo --no-foo" is eq. to "cmd --no-foo"

should be valid universally. In the long run, we might even try and convert revision.c to parse_options, thereby gaining --no-foo for every --foo.

So, my RFD really consists of two things:
- provide a way to override --no-merges/no_merges
- sane naming
The first step + half of the second could be achieved by:
- provide "--merges-also" which does "no_merges = 0"
- provide "--merges-only" which does "merges_only = 1", i.e. an alias
for current "--merges"

"--merges-also --no-merges" would be "--no-merges" and vice versa. "--merges-also --merges-only" would be "--merges-only" "--merges-only --merges-also" would be "--merges-only" which all make sense sematically

"--merges-only --no-merges" would be no commits with the current implementation (just like "--merges --no-merges"), but we could catch this case easily and make it do "--no-merges".

I don't think we need to care about keeping the current behavior of "--merges --no-merges", do we?

So, no breakage here. Along with it we could issue deprecation notices in doc and relnotes for "--merges" or just make them less visible. That is, it would serve the same purpose as Junio's tri-state option.

In 2.0 or so, we could change "--merges" to be an alias for "--merges-also" rather than "--merges-only" (but don't have to).

>From the ui perspective I'm somehow not a big fan of tri-state options

but can't give hard reasons why; maybe because they force you to use option arguments. Also, the only reasonable name for a tri-state option would be "--merges". Can a tri-state have a default? Then we could default "--merges" to the current behavior, i.e. "--merges=only" (assuming we have "--merges=only/also/no").

Junio: Sorry for making you explain "D" more rather than doing it myself
upfront.
Michael
Previous: Jeff KingNext: Junio C Hamano
Message 6 of 67 in “revision.c: --merges, --no-merges and --merges-only”
  1. 0/2 revision.c: --merges, --no-merges and --merges-onlyMichael J Gruber, Mar 17, 2011
  2. 1/2 revision.c: rename --merges to --merges-onlyMichael J Gruber, Mar 17, 2011
  3. 2/2 revision.c: introduce --merges to undo --no-mergesMichael J Gruber, Mar 17, 2011
  4. Junio C HamanoMar 17, 2011
  5. Jeff KingMar 17, 2011
  6. Michael J GruberMar 18, 2011
  7. Junio C HamanoMar 18, 2011
  8. Michael J GruberMar 18, 2011
  9. Jeff KingMar 18, 2011
  10. 0/3 rev-list and friends: --min-parents, --max-parentsMichael J Gruber, Mar 18, 2011
  11. Michael J GruberMar 18, 2011
  12. Jeff KingMar 18, 2011
  13. Michael J GruberMar 21, 2011
  14. 0/3 rev-list and friends: --min-parents, --max-parentsMichael J Gruber, Mar 21, 2011
  15. Jeff KingMar 21, 2011
  16. 0/5 rev-list and friends: --min-parents, --max-parentsMichael J Gruber, Mar 23, 2011
  17. Jeff KingMar 23, 2011
  18. Junio C HamanoMar 23, 2011
  19. Junio C HamanoMar 23, 2011
  20. Jonathan NiederMar 24, 2011
  21. Michael J GruberMar 24, 2011
  22. Jonathan NiederMar 24, 2011
  23. 0/2 test_when_finished and returning earlyJonathan Nieder, Aug 8, 2011
  24. 1/2 test: simplify return value of test_run_Jonathan Nieder, Aug 8, 2011
  25. 2/2 test: cope better with use of return for errorsJonathan Nieder, Aug 8, 2011
  26. Johannes SixtAug 9, 2011
  27. Jeff KingAug 9, 2011
  28. t3900: do not reference numbered arguments from the test scriptJohannes Sixt, Aug 11, 2011
  29. Jonathan NiederAug 11, 2011
  30. Junio C HamanoAug 11, 2011
  31. Jeff KingAug 8, 2011
  32. 1/5 t6009: use test_commit() from test-lib.shMichael J Gruber, Mar 23, 2011
  33. 2/5 revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 23, 2011
  34. 3/5 squash! revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 23, 2011
  35. 4/5 rev-list --min-parents,--max-parents: doc, test and completionMichael J Gruber, Mar 23, 2011
  36. 5/5 fixup! rev-list --min-parents,--max-parents: doc, test and completionMichael J Gruber, Mar 23, 2011
  37. 1/3 t6009: use test_commit() from test-lib.shMichael J Gruber, Mar 21, 2011
  38. 2/3 revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 21, 2011
  39. Michael J GruberMar 21, 2011
  40. Junio C HamanoMar 21, 2011
  41. Jonathan NiederMar 21, 2011
  42. 3/3 rev-list --min-parents,--max-parents: doc and test and completionMichael J Gruber, Mar 21, 2011
  43. Jonathan NiederMar 21, 2011
  44. Michael J GruberMar 22, 2011
  45. Jonathan NiederMar 23, 2011
  46. 1/3 revision.c: introduce --min-parents and --max-parentsMichael J Gruber, Mar 18, 2011
  47. Jeff KingMar 18, 2011
  48. Michael J GruberMar 21, 2011
  49. Jonathan NiederMar 18, 2011
  50. Junio C HamanoMar 18, 2011
  51. Michael J GruberMar 21, 2011
  52. 2/3 t6009: use test_commit() from test-lib.shMichael J Gruber, Mar 18, 2011
  53. 3/3 rev-list --min-parents,--max-parents: doc and test and completionMichael J Gruber, Mar 18, 2011
  54. Jeff KingMar 18, 2011
  55. Michael J GruberMar 21, 2011
  56. Jeff KingMar 21, 2011
  57. Michael J GruberMar 21, 2011
  58. Junio C HamanoMar 21, 2011
  59. Michael J GruberMar 21, 2011
  60. Junio C HamanoMar 21, 2011
  61. Jonathan NiederMar 18, 2011
  62. Michael J GruberMar 21, 2011
  63. Jonathan NiederMar 21, 2011
  64. Michael J GruberMar 22, 2011
  65. Jeff KingMar 18, 2011
  66. Michael J GruberMar 18, 2011
  67. Jeff KingMar 18, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.