Re: [PATCH] checkout: add --autostash option for branch switching
Show 9 quoted lines
> This tries to create a root-level ref called CHECKOUT_AUTOSTASH, which
> violates the syntax rules given in gitglossary's "ref" entry:
>
> Ref names must either start with refs/ or be located in the root of
> the hierarchy. For the latter, their name must follow these rules:
>
> • The name consists of only upper-case characters or underscores.
>
> • The name ends with "_HEAD" or is equal to "HEAD".
So maybe easiest is just to rename it to CHECKOUT_AUTOSTASH_HEAD?
Harald