From: Harald Nordgren Date: Sat, 11 Apr 2026 18:51:09 GMT Subject: Re: [PATCH] checkout: add --autostash option for branch switching Message-ID: <20260411185109.37795-1-haraldnordgren@gmail.com> In-Reply-To: <20260411183823.GA672575@coredump.intra.peff.net> > This tries to create a root-level ref called CHECKOUT_AUTOSTASH, which > violates the syntax rules given in gitglossary's "ref" entry: > > Ref names must either start with refs/ or be located in the root of > the hierarchy. For the latter, their name must follow these rules: > > • The name consists of only upper-case characters or underscores. > > • The name ends with "_HEAD" or is equal to "HEAD". So maybe easiest is just to rename it to CHECKOUT_AUTOSTASH_HEAD? Harald