Re: [PATCH] checkout: add --autostash option for branch switching
- From
Jeff King <peff@peff.net>
- Date
- Apr 11, 2026, 19:11 UTC
- Message-ID
- <20260411191103.GA774963@coredump.intra.peff.net>
- In-Reply-To
- <20260411185109.37795-1-haraldnordgren@gmail.com>
On Sat, Apr 11, 2026 at 08:51:09PM +0200, Harald Nordgren wrote:
Show 12 quoted lines
> > This tries to create a root-level ref called CHECKOUT_AUTOSTASH, which > > violates the syntax rules given in gitglossary's "ref" entry: > > > > Ref names must either start with refs/ or be located in the root of > > the hierarchy. For the latter, their name must follow these rules: > > > > • The name consists of only upper-case characters or underscores. > > > > • The name ends with "_HEAD" or is equal to "HEAD". > > > So maybe easiest is just to rename it to CHECKOUT_AUTOSTASH_HEAD?
Yeah, that is syntactically valid, if a mouthful. I can't offhand think of a shorter variant.
-Peff