[PATCH v2 00/15] SHA-1/SHA-256 interoperability, part 2
- From
brian m. carlson <sandals@crustytoothpaste.net>
- Date
- Nov 17, 2025, 22:16 UTC
- Message-ID
- <20251117221621.2863243-1-sandals@crustytoothpaste.net>
- In-Reply-To
- <20251027004404.2152927-1-sandals@crustytoothpaste.net>
This is the second part of the SHA-1/SHA-256 interoperability work. It introduces our first major use of Rust code to implement a object map format as well as preparatory work to make that happen, including changing types to more Rust-friendly ones. Since Rust will be required for the interoperability work, we require that in the testsuite.
We also verify that our object ID algorithm is valid when looking up data in the hash map since the Rust code intentionally has no knowledge about global mutable state like the_repository and so cannot default to the main hash algorithm when we've zero-initialized a struct object_id.
The advantage to this Rust code is that it is comprehensively tested with unit testing. We can serialize our object map and then verify that we can also load it again and perform various testing, such as whether certain object IDs are found in the map and mapped correctly. We can also test our slightly subtle custom binary search code effectively and be confident that it works, since Rust doesn't provide a way to binary search slices of variable length.
I have opted not to use an enum type for our hash algorithm and have preserved the use of uint32_t from v1. A C enum type would not map one-to-one with the Rust type (since the C version would use GIT_HASH_UNKNOWN for unknown values and Rust would use None instead), so to avoid problems as we generate more of the integration code with bindgen and cbindgen, I've chosen to leave it as it is.
Changes since v1:
* Use `MAYBE_UNUSED` instead of casting. * Explain reason for `ObjectID` structure. * Switch to `Result` in hash algorithm abstraction. * Add some additional helpers to `ObjectID`. * Rename function to `hash_algo_ptr_by_number`. * Switch to `xmalloc`. * Fix `build.rs` to use syntax compatible with Rust 1.63. * Remove unneeded libraries from `build.rs`. * Improve Rust documentation. * Explain that safe hashing is about untrusted data, not memory safety. * Add a trait for hashing to allow for future unsafe (trusted data) hashing. * Rename `Hasher` to `CryptoHasher`. * Remove description of legacy loose object map. * Rename loose object map to object map. * Update documentation for object map to be clearer about padding, alignment, and endianness. * Explain which hash algorithm is used in object map. * Remove mention of chunks in object map in favour of generic "additional data". * Fix indentation in object map documentation. * Generally clarify object map documentation. * Fix clippy warnings in Rust code.
brian m. carlson (15): repository: require Rust support for interoperability conversion: don't crash when no destination algo hash: use uint32_t for object_id algorithm rust: add a ObjectID struct rust: add a hash algorithm abstraction hash: add a function to look up hash algo structs rust: add additional helpers for ObjectID csum-file: define hashwrite's count as a uint32_t write-or-die: add an fsync component for the object map hash: expose hash context functions to Rust rust: add a build.rs script for tests rust: add functionality to hash an object rust: add a new binary object map format rust: add a small wrapper around the hashfile code object-file-convert: always make sure object ID algo is valid
Documentation/gitformat-loose.adoc | 78 +++ Makefile | 5 +- build.rs | 17 + csum-file.c | 2 +- csum-file.h | 2 +- hash.c | 48 +- hash.h | 38 +- object-file-convert.c | 14 +- oidtree.c | 2 +- repository.c | 12 +- repository.h | 4 +- serve.c | 2 +- src/csum_file.rs | 81 +++ src/hash.rs | 466 +++++++++++++++ src/lib.rs | 3 + src/loose.rs | 913 +++++++++++++++++++++++++++++ src/meson.build | 3 + t/t1006-cat-file.sh | 82 ++- t/t1016-compatObjectFormat.sh | 6 + t/t1500-rev-parse.sh | 2 +- t/t9305-fast-import-signatures.sh | 4 +- t/t9350-fast-export.sh | 4 +- t/test-lib.sh | 4 + write-or-die.h | 4 +- 24 files changed, 1722 insertions(+), 74 deletions(-) create mode 100644 build.rs create mode 100644 src/csum_file.rs create mode 100644 src/hash.rs create mode 100644 src/loose.rs