Re: [PATCH v8 0/3]
- From
Jeff King <peff@peff.net>
- Date
- Feb 21, 2019, 12:36 UTC
- Message-ID
- <20190221123646.GA12185@sigill.intra.peff.net>
- In-Reply-To
- <20190219083123.27686-1-nbelakovski@gmail.com>
On Tue, Feb 19, 2019 at 05:31:20PM +0900, nbelakovski@gmail.com wrote:
Show 9 quoted lines
> From: Nickolai Belakovski <nbelakovski@gmail.com> > > I've made the various cosmetic changes that were suggested, as well as adding tests for 3/3 > > I don't have a particularly strong opinion on the subject of keeping the atom as "worktreepath" > or changing it to "worktree:path". We did feel earlier in this thread that if we went with > "worktree:path", then "worktree" is somewhat ambiguous, and that discussion led to deciding to > have "worktree" return the path,. After that I chose to name it "worktreepath" because I like to > make things explicit and intuitive.
I am OK with it either way. We have used ":" for some variants (e.g., objectsize:disk). But we have also used long single names with related prefixes (e.g., objectname versus objecttype versus objectsize).
Patch 1 looks good to me. Given that we're on v8 and most of the other comments are for patches 2 and 3, I think we might consider graduating it separately if the other two are not ready soon. It's independently useful, IMHO.
I have a few comments on the others which I'll leave as replies there.
-Peff