[PATCH v2 0/7] remote-mediawiki: add namespace support
- From
Antoine Beaupré <anarcat@debian.org>
- Date
- Oct 30, 2017, 02:51 UTC
- Message-ID
- <20171030025142.19421-1-anarcat@debian.org>
- In-Reply-To
- <20171029160857.29460-2-anarcat@debian.org>
This patch series tries to integrate all the feedback received in the recent review from Eric Sunshine. It completely removes the confusing changes to get_mw_namespace_id_for_page() because I believe they are unrelated to the namespace support.
I also split up the last patch in 4 different patches for clarity and fixed the vocabulary (it's "virtual" namespaces, not "special", which is a specific namespace).
I left that die() in there because it makes the code a little cleaner and I'm lazy.
Thanks again for the good feedback!