Re: [PATCH v5 01/14] Add data structures and basic functions for commit trailers
- From
Christian Couder <chriscool@tuxfamily.org>
- Date
- Feb 9, 2014, 13:51 UTC
- Message-ID
- <20140209.145103.574296288999775548.chriscool@tuxfamily.org>
- In-Reply-To
- <xmqqvbwrx0sh.fsf@gitster.dls.corp.google.com>
From: Junio C Hamano <gitster@pobox.com>
Show 13 quoted lines
>
> Christian Couder <chriscool@tuxfamily.org> writes:
>
>> + enum action_if_exist if_exist;
>> + enum action_if_missing if_missing;
>
> Probably "if_exists" is more gramatically correct.
>
> if (x->if_exists) {
> ... do this ...
> }
>
> would read well, but not "x->if_exist". Ok, I will use "if_exists" instead of "if_exist" and also:
enum action_if_exists { EXISTS_ADD_IF_DIFFERENT, EXISTS_ADD_IF_DIFFERENT_NEIGHBOR,
EXISTS_ADD, EXISTS_OVERWRITE, EXISTS_DO_NOTHING };instead of:
enum action_if_exist { EXIST_ADD_IF_DIFFERENT, EXIST_ADD_IF_DIFFERENT_NEIGHBOR,
EXIST_ADD, EXIST_OVERWRITE, EXIST_DO_NOTHING };to be consistent.
Thanks, Christian.