From: Karl Hasselström Date: Thu, 05 Jun 2008 06:46:33 GMT Subject: Re: [StGIT PATCH 2/5] Rename Repository.head to Repository.head_ref Message-ID: <20080605064633.GB23209@diana.vm.bytemark.co.uk> In-Reply-To: <20080604211325.32531.84968.stgit@localhost.localdomain> On 2008-06-04 22:13:25 +0100, Catalin Marinas wrote: > This is to avoid confusion with the Stack.head function which > returns a commit object rather than a file name. A much better name. But you don't fix any callers -- aren't there any? > The patch also changes the "new" function to use stack.head directly > rather than via the Repository.refs... object. Oh, here's a caller. But just one. -- Karl Hasselström, kha@treskal.com www.treskal.com/kalle