git/list[1] front-page[2] threads[3] people[4] search[5] about
 

What's cooking in git/spearce.git (topics)

From
Shawn O. Pearce <spearce@spearce.org>
Date
Oct 22, 2007, 06:32 UTC
Message-ID
<20071022063222.GS14735@spearce.org>

Here are the topics that have been cooking. Commits prefixed with '-' are only in 'pu' while commits prefixed with '+' are in 'next'. The topics list the commits in reverse chronological order.

* cc/skip (Mon Oct 22 07:49:39 2007 +0200) 9 commits
 - Bisect: add a "bisect replay" test case.
 - Bisect: add "bisect skip" to the documentation.
 - Bisect: factorise "bisect_{bad,good,skip}" into "bisect_state".
 - Bisect: factorise some logging into "bisect_write".
 - Bisect: factorise "bisect_write_*" functions.
 - Bisect: implement "bisect skip" to mark untestable revisions.
 - Bisect: fix some white spaces and empty lines breakages.
 - rev-list documentation: add "--bisect-all".
 - rev-list: implement --bisect-all

Recently updated to use "skip". I haven't had a chance to look at this series so it just parked in pu for now.

* ds/gitweb (Mon Oct 22 10:28:03 2007 +1000) 1 commit
 + gitweb: Provide title attributes for abbreviated author names.
* lt/rename (Sun Oct 21 16:59:03 2007 -0700) 2 commits
 - Linear-time/space rename logic (exact renames only)
 - Split out "exact content match" phase of rename detection

t4001-diff-rename.sh failed while running tests on pu. I'm pretty sure its this topic from Linus. Need to look at it further.

* js/PATH (Sun Oct 21 22:59:01 2007 +0100) 1 commit
 - execv_git_cmd(): also try PATH if everything else fails.

I raised a concern about GIT_EXEC_PATH="" making $PATH search before the compiled in path, which is certainly new behavior and I don't think its quite what was intended. Parked in pu until I hear back.

* sp/help-exit0 (Sun Oct 21 14:47:45 2007 -0700) 1 commit
 . "git help" and "git help -a" shouldn't exit(1) unless they error

Breaks things because "git" (no arguments) no exits successful, which is less than ideal. Only "git help" and "git help branch" should be exiting successful.

* ja/shorthelp (Sun Oct 21 01:41:41 2007 +0300) 1 commit
 + On error, do not list all commands, but point to --help option
This I like.  We'll see what the list thinks while using next.  :)
* db/fetch-pack (Sat Oct 20 16:03:49 2007 -0400) 60 commits
 + Define compat version of mkdtemp for systems lacking it
 + Avoid scary errors about tagged trees/blobs during git-fetch
 + fetch: if not fetching from default remote, ignore default merge
 + Support 'push --dry-run' for http transport
 + Support 'push --dry-run' for rsync transport
 + Fix 'push --all branch...' error handling
 + Fix compilation when NO_CURL is defined
 + Added a test for fetching remote tags when there is not tags.
 + Fix a crash in ls-remote when refspec expands into nothing
 ... and many many more ...

I think this is just about ready to graduate to master. I haven't seen any major problems with it since the recent fixes were put in. I'd like to see it move over soon as a number of other topics are based upon the tip of this topic rather than master itself. But obviously code quality is more important than topic organization.

* js/forkexec (Fri Oct 19 21:48:06 2007 +0200) 74 commits
 + Use the asyncronous function infrastructure to run the content
   filter.
 + Avoid a dup2(2) in apply_filter() - start_command() can do it for
   us.
 + t0021-conversion.sh: Test that the clean filter really cleans
   content.
 + upload-pack: Run rev-list in an asynchronous function.
 + upload-pack: Move the revision walker into a separate function.
 + Use the asyncronous function infrastructure in builtin-fetch-
   pack.c.
 + Add infrastructure to run a function asynchronously.
 + upload-pack: Use start_command() to run pack-objects in
   create_pack_file().
 + Have start_command() create a pipe to read the stderr of the
   child.
 + Use start_comand() in builtin-fetch-pack.c instead of explicit
   fork/exec.
 + Use run_command() to spawn external diff programs instead of
   fork/exec.
 + Use start_command() to run content filters instead of explicit
   fork/exec.
 + Use start_command() in git_connect() instead of explicit
   fork/exec.
 + Change git_connect() to return a struct child_process instead of a
   pid_t.
 ... db/fetch-pack begins here ...

This looked sane to me and makes it easier for the MinGW port. Plus its an overal reduction in code, reusing the run-command framework to avoid lots of ugly pipe() and dup2() calls. Its parked in next for a while to get some testing but is probably fine to move to master in the near future.

* tf/afs (Fri Oct 19 07:38:16 2007 -0500) 1 commit
 - Better support AFS hardlinking across object directories

I'd rather rewrite this by putting the temporary files directly into their final object directory, then hardlinking within that directory. This should work on Coda and AFS, leaving only the FAT filesystem as the odd-duck that needs to use rename(). But maybe I'm just being really paranoid about not allowing an object to be replaced.

* jk/terse-fetch (Fri Oct 19 03:40:57 2007 -0400) 62 commits
 - park
 - git-fetch: mega-terse fetch output
 ... db/fetch-pack begins here ...

Much discussion on the list about this topic. I think we may have come to an agreement about what the output should look like, but this topic doesn't implement that output format. Someone needs to either update this topic or rewrite it. Starting from Jeff King's patch makes things a lot easier.

* np/progress (Fri Oct 19 01:01:40 2007 -0400) 9 commits
 + Stop displaying "Pack pack-$ID created." during git-gc
 + Teach prune-packed to use the standard progress meter
 + Change 'Deltifying objects' to 'Compressing objects'
 + fix for more minor memory leaks
 + fix const issues with some functions
 + pack-objects.c: fix some global variable abuse and memory leaks
 + pack-objects: no delta possible with only one object in the list
 + cope with multiple line breaks within sideband progress messages
 + more compact progress display

I really like the new progress display that Nico implemented here, and also the terser and more user friendly output from git-repack. Needs more time for testing, but its pretty obvious code changes and should be able to graduate to master in the near future.

* sp/mergetool (Thu Oct 18 12:25:34 2007 +0200) 3 commits
 + mergetool: avoid misleading message "Resetting to default..."
 + mergetool: add support for ECMerge
 + mergetool: use path to mergetool in config var
   mergetool.<tool>.path

Probably fine for master as-is. I personally don't use mergetool so I'd appreciate an Ack from someone who does that these are working well for them.

* jk/send-pack (Thu Oct 18 02:17:46 2007 -0400) 2 commits
 + t5516: test update of local refs on push
 + send-pack: don't update tracking refs on error

This probably should graduate to master soon. It just delays updating the tracking refs until after we've made sure all refs were updated. I'll give it a few more days and then likely kick it over to master.

* js/rebase (Wed Oct 17 10:31:35 2007 +0100) 1 commit
 + Fixing path quoting in git-rebase

Simple change, but rebase is a key tool. I'll probably give this a few more days and then kick it over.

* js/reflog-delete (Wed Oct 17 02:50:45 2007 +0100) 1 commit
 + Teach "git reflog" a subcommand to delete single entries

Waiting to hear if we're doing anything further with this. it was originally created to help "git stash" perform a pop, but nobody has come forth with a patch for git-stash that uses this feature. I'd like to have a real use for it that actually tests this code in a more production setting before it merges to master.

* dz/color-addi (Tue Oct 16 21:42:23 2007 -0400) 1 commit
 - Add color support to git-add--interactive

I'm just parking this here in case anyone wants to pick this up and continue it further. I described on list to the original author a number of problems with why this isn't in next yet; the author said they will need a little bit of time before they can address that list.

* ph/parseopt (Mon Oct 15 23:06:02 2007 +0200) 22 commits
 - Make builtin-pack-refs.c use parse_options.
 - Make builtin-name-rev.c use parse_options.
 - Make builtin-count-objects.c use parse_options.
 - Make builtin-fsck.c use parse_options.
 - Update manpages to reflect new short and long option aliases
 - Make builtin-for-each-ref.c use parse-opts.
 - Make builtin-symbolic-ref.c use parse_options.
 - Make builtin-update-ref.c use parse_options
 - Make builtin-revert.c use parse_options.
 - Make builtin-describe.c use parse_options
 - Make builtin-branch.c use parse_options.
 - Make builtin-mv.c use parse-options
 - Make builtin-rm.c use parse_options.
 - Port builtin-add.c to use the new option parser.
 - parse-options: allow callbacks to take no arguments at all.
 - parse-options: Allow abbreviated options when unambiguous
 - Add shortcuts for very often used options.
 - parse-options: make some arguments optional, add callbacks.
 - Rework make_usage to print the usage message immediately
 - Add tests for parse-options.c
 - parse-options: be able to generate usages automatically
 - Add a simple option parser.

There's actually a few other commits (3?) missing from the above list that are safely parked away in my tree. I'm most of the way through reviewing these and have made a few bug fixes and style nit corrections in the earlier parts of the series. I'm going to try and finish working through this series tomorrow and then will probably merge it to next.

The other 3 commits are hanging off to the side as 2 of them are for the top of db/fetch-pack (to port builtin-fetch and friends to the new option parser) and the 3rd is a somewhat questionable change due to needing to rename a "-h" to a "-H". I just got tired of rebasing these 3 other commits onto the respective topics. I'm waiting for the core option parser (above) to freeze on a commit SHA-1 before I deal with these again.

* sp/push-refspec (Sun Oct 14 10:54:45 2007 +0200) 6 commits
 - push, send-pack: use same rules as git-rev-parse to resolve
   refspecs
 - add ref_cmp_full_short() comparing full ref name with a short name
 - push, send-pack: support pushing HEAD to real ref name
 - rev-parse: teach "git rev-parse --symbolic" to print the full ref
   name
 - add get_sha1_with_real_ref() returning full name of ref on demand
 - push, send-pack: fix test if remote branch exists for colon-less
   refspec

I've briefly looked at this series and there's reasons why its not in next yet. Its actually something that I'm interested in seeing fixed as the current behavior of how git-push matches refs on the remote side is just plain nuts. I'll look at it further after I get ph/parseopt and cc/skip into next.

* jc/spht (Tue Oct 2 18:00:27 2007 -0700) 1 commit
 - git-diff: complain about >=8 consecutive spaces in initial indent
* jc/nu (Mon Oct 1 19:35:12 2007 -0700) 2 commits
 - PARK a bit more work
 - (PARK) WIP
I inherited these from Junio.  No change.
* kh/commit (Mon Sep 17 20:06:47 2007 -0400) 4 commits
 + Export rerere() and launch_editor().
 + Introduce entry point add_interactive and add_files_to_cache
 + Enable wt-status to run against non-standard index file.
 + Enable wt-status output to a given FILE pointer.
Waiting on ph/parseopt (above) and other stuff for builtin-commit.
* jc/pathspec (Thu Sep 13 13:38:19 2007 -0700) 3 commits
 - pathspec_can_match(): move it from builtin-ls-tree.c to tree.c
 - ls-tree.c: refactor show_recursive() and rename it.
 - tree-diff.c: split out a function to match a single pattern.
Also inherited from Junio.  No change.
* js/stash-create (Mon Jul 9 00:51:23 2007 -0700) 2 commits
 + rebase: allow starting from a dirty tree.
 + stash: implement "stash create"

I actually had the "dirty work tree stash in rebase" thing trip on me recently and I got a little pissed off about it. The behavior was not what I expected, nor what I wanted, at that particular point in time. Actually I wanted git-rebase to stop and *not* attempt the rebase because of the dirty work tree. So I'm not feeling the "auto stash" love right now.

-- 
Shawn.
Next: Jeff King
Message 1 of 168 in “What's cooking in git/spearce.git (topics)”
  1. Shawn O. PearceOct 22, 2007
  2. Jeff KingOct 22, 2007
  3. Jeff KingOct 22, 2007
  4. Linus TorvaldsOct 23, 2007
  5. Jeff KingOct 23, 2007
  6. Pierre HabouzitOct 22, 2007
  7. Steffen ProhaskaOct 22, 2007
  8. Junio C HamanoOct 23, 2007
  9. Shawn O. PearceOct 23, 2007
  10. What's cooking in git.git (topics)Junio C Hamano, Oct 24, 2007
  11. David SymondsOct 24, 2007
  12. Scott ParishOct 24, 2007
  13. Andreas EricssonOct 24, 2007
  14. Scott ParishOct 25, 2007
  15. What's cooking in git.git (topics)Junio C Hamano, Nov 1, 2007
  16. Jakub NarebskiNov 1, 2007
  17. Junio C HamanoNov 1, 2007
  18. Linus TorvaldsNov 1, 2007
  19. Geert BoschNov 1, 2007
  20. Junio C HamanoNov 1, 2007
  21. Mike HommeyNov 1, 2007
  22. Junio C HamanoNov 1, 2007
  23. Junio C HamanoNov 2, 2007
  24. Pierre HabouzitNov 1, 2007
  25. Geert BoschNov 1, 2007
  26. Jonas FonsecaNov 2, 2007
  27. Theodore TsoNov 1, 2007
  28. Melchior FRANZNov 1, 2007
  29. Johan HerlandNov 1, 2007
  30. Junio C HamanoNov 1, 2007
  31. Linus TorvaldsNov 1, 2007
  32. Bill LearNov 1, 2007
  33. Junio C HamanoNov 1, 2007
  34. Petr BaudisNov 2, 2007
  35. Pierre HabouzitNov 1, 2007
  36. Andreas EricssonNov 2, 2007
  37. Pierre HabouzitNov 1, 2007
  38. Jakub NarebskiNov 2, 2007
  39. Petr BaudisNov 2, 2007
  40. Jakub NarebskiNov 2, 2007
  41. Jakub NarebskiNov 2, 2007
  42. Pierre HabouzitNov 2, 2007
  43. Miles BaderNov 2, 2007
  44. Miles BaderNov 2, 2007
  45. Andreas EricssonNov 2, 2007
  46. Johannes SchindelinNov 2, 2007
  47. Brian DowningNov 1, 2007
  48. Pierre HabouzitNov 1, 2007
  49. Wincent ColaiutaNov 2, 2007
  50. What's cooking in git.git (topics)Junio C Hamano, Nov 4, 2007
  51. Jakub NarebskiNov 4, 2007
  52. Pierre HabouzitNov 4, 2007
  53. What's cooking in git.git (topics)Junio C Hamano, Nov 8, 2007
  54. Steffen ProhaskaNov 8, 2007
  55. What's cooking in git.git (topics)Junio C Hamano, Nov 12, 2007
  56. Johannes SchindelinNov 12, 2007
  57. Pierre HabouzitNov 12, 2007
  58. Johannes SchindelinNov 12, 2007
  59. rebase: brown paper bag fix after the detached HEAD patchJohannes Schindelin, Nov 12, 2007
  60. Pierre HabouzitNov 12, 2007
  61. Steffen ProhaskaNov 12, 2007
  62. Johannes SchindelinNov 12, 2007
  63. 1/2 push: Add '--matching' option and print warning if it should be usedSteffen Prohaska, Nov 18, 2007
  64. 2/2 push: Add '--current', which pushes only the current branchSteffen Prohaska, Nov 18, 2007
  65. Junio C HamanoNov 19, 2007
  66. Steffen ProhaskaNov 19, 2007
  67. Junio C HamanoNov 19, 2007
  68. Junio C HamanoNov 19, 2007
  69. Andreas EricssonNov 19, 2007
  70. Steffen ProhaskaNov 19, 2007
  71. Junio C HamanoNov 19, 2007
  72. Steffen ProhaskaNov 19, 2007
  73. push: Add "--current", which pushes only the current branchSteffen Prohaska, Nov 19, 2007
  74. Jakub NarebskiNov 19, 2007
  75. Junio C HamanoNov 19, 2007
  76. Jakub NarebskiNov 19, 2007
  77. Junio C HamanoNov 19, 2007
  78. Jakub NarebskiNov 19, 2007
  79. Andreas EricssonNov 19, 2007
  80. git-commit: Add tests for invalid usage of -a/--interactive with pathsBjörn Steinbrink, Nov 12, 2007
  81. What's cooking in git.git (topics)Junio C Hamano, Nov 15, 2007
  82. Johannes SchindelinNov 15, 2007
  83. t7501-commit: Add test for git commit <file> with dirty index.Kristian Høgsberg, Nov 15, 2007
  84. Johannes SchindelinNov 15, 2007
  85. builtin-commit: fix "git add x y && git commit y" committing x, tooJohannes Schindelin, Nov 15, 2007
  86. Johannes SchindelinNov 15, 2007
  87. Kristian HøgsbergNov 15, 2007
  88. Johannes SchindelinNov 16, 2007
  89. Junio C HamanoNov 17, 2007
  90. Junio C HamanoNov 18, 2007
  91. Jeff KingNov 17, 2007
  92. What's cooking in git.git (topics)Junio C Hamano, Nov 17, 2007
  93. Alex RiesenNov 17, 2007
  94. Junio C HamanoNov 18, 2007
  95. What's cooking in git.git (topics)Junio C Hamano, Nov 21, 2007
  96. What's cooking in git.git (topics)Junio C Hamano, Nov 23, 2007
  97. Jeff KingNov 23, 2007
  98. Johannes SchindelinNov 23, 2007
  99. Jeff KingNov 24, 2007
  100. Nicolas PitreNov 24, 2007
  101. Junio C HamanoNov 24, 2007
  102. J. Bruce FieldsNov 25, 2007
  103. Junio C HamanoNov 25, 2007
  104. J. Bruce FieldsNov 25, 2007
  105. Nicolas PitreNov 26, 2007
  106. J. Bruce FieldsNov 26, 2007
  107. Nicolas PitreNov 26, 2007
  108. J. Bruce FieldsNov 26, 2007
  109. Jakub NarebskiNov 26, 2007
  110. Andreas EricssonNov 26, 2007
  111. Nicolas PitreNov 26, 2007
  112. David KastrupNov 26, 2007
  113. Nicolas PitreNov 26, 2007
  114. Junio C HamanoNov 26, 2007
  115. David KastrupNov 26, 2007
  116. Nicolas PitreNov 26, 2007
  117. David KastrupNov 26, 2007
  118. Nicolas PitreNov 26, 2007
  119. David KastrupNov 26, 2007
  120. Nicolas PitreNov 26, 2007
  121. David KastrupNov 26, 2007
  122. Nicolas PitreNov 27, 2007
  123. Miles BaderDec 5, 2007
  124. Jakub NarebskiNov 26, 2007
  125. Johannes SchindelinNov 26, 2007
  126. Nicolas PitreNov 26, 2007
  127. Jan HudecNov 26, 2007
  128. What's cooking in git.git (topics)Junio C Hamano, Nov 25, 2007
  129. Jakub NarebskiNov 25, 2007
  130. J. Bruce FieldsNov 25, 2007
  131. What's cooking in git.git (topics)Junio C Hamano, Dec 1, 2007
  132. Eric WongDec 1, 2007
  133. Add 'git fast-export', the sister of 'git fast-import'Johannes Schindelin, Dec 2, 2007
  134. Johannes SchindelinDec 2, 2007
  135. What's cooking in git.git (topics)Junio C Hamano, Dec 4, 2007
  136. Johannes SixtDec 4, 2007
  137. msysGit on FAT32 (was: What's cooking in git.git (topics))Jakub Narebski, Dec 4, 2007
  138. Johannes SchindelinDec 4, 2007
  139. Johannes SixtDec 4, 2007
  140. Johannes SchindelinDec 4, 2007
  141. Steffen ProhaskaDec 4, 2007
  142. What's cooking in git.git (topics)Junio C Hamano, Dec 5, 2007
  143. Jakub NarebskiDec 5, 2007
  144. Jakub NarebskiDec 5, 2007
  145. Jeff KingDec 6, 2007
  146. Soft aliases: add "less" and minimal documentationJohannes Schindelin, Dec 5, 2007
  147. Junio C HamanoDec 5, 2007
  148. Jeff KingDec 6, 2007
  149. Jeff KingDec 6, 2007
  150. What's cooking in git.git (topics)Junio C Hamano, Dec 7, 2007
  151. Jakub NarebskiDec 7, 2007
  152. Junio C HamanoDec 7, 2007
  153. Miklos VajnaDec 7, 2007
  154. What's cooking in git.git (topics)Junio C Hamano, Dec 9, 2007
  155. What's cooking in git.git (topics)Junio C Hamano, Dec 13, 2007
  156. Nicolas PitreDec 13, 2007
  157. 1/2 xdl_diff: identify call sites.Junio C Hamano, Dec 13, 2007
  158. Junio C HamanoDec 14, 2007
  159. 2/2 xdi_diff: trim common trailing linesJunio C Hamano, Dec 13, 2007
  160. Peter BaumannDec 14, 2007
  161. Junio C HamanoDec 14, 2007
  162. What's cooking in git.git (topics)Junio C Hamano, Dec 17, 2007
  163. What's cooking in git.git (topics)Junio C Hamano, Dec 23, 2007
  164. checkout --push/--pop idea (Re: What's cooking in git.git (topics))Jan Hudec, Dec 31, 2007
  165. What's cooking in git.git (topics)Junio C Hamano, Jan 5, 2008
  166. Johannes SchindelinJan 5, 2008
  167. What will be cooking in git.git post 1.5.4 (topics)Junio C Hamano, Jan 22, 2008
  168. Brian DowningDec 4, 2007

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.