# [PATCH 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'

5 messages from 2020-04-02 to 2020-04-03. Participants: Shourya Shukla, Junio C Hamano.
Thread: https://gitlist.dev/t/53160

## Shourya Shukla, 2020-04-02 22:58

Subject: [PATCH 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
Message-ID: <20200402225807.8603-1-shouryashukla.oo@gmail.com>
URL: https://gitlist.dev/e/20200402225807.8603-1-shouryashukla.oo%40gmail.com

```
Subcommands in 'submodule--helper.c' which give a callback to other functions
have structures and macros named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT'
respectively.

The subcommand 'foreach' did not follow this convention and therefore had the naming of
the form: 'struct foreach_cb' and 'CB_FOREACH_INIT'. Rename these to: 'struct foreach_cb'
and 'FOREACH_CB_INIT' respectively.


Shourya Shukla (1):
  submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'

 builtin/submodule--helper.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

-- 
2.20.1


```

## Shourya Shukla, 2020-04-02 22:58

Subject: [PATCH 1/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
Message-ID: <20200402225807.8603-2-shouryashukla.oo@gmail.com>
URL: https://gitlist.dev/e/20200402225807.8603-2-shouryashukla.oo%40gmail.com
In-Reply-To: <20200402225807.8603-1-shouryashukla.oo@gmail.com>

```
In 'submodule--helper.c', the structures and macros for callbacks belonging
to any subcommand are named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT'
respectively.

This was an exception for the subcommand 'foreach' of the command
'submodule'. Rename the aforementioned structures and macros:
'struct cb_foreach' to 'struct foreach_cb' and 'CB_FOREACH_INIT'
to 'FOREACH_CB_INIT'.

Signed-off-by: Shourya Shukla <shouryashukla.oo@gmail.com>
---
 builtin/submodule--helper.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/builtin/submodule--helper.c b/builtin/submodule--helper.c
index 7d5996d3b3..a21e48730d 100644
--- a/builtin/submodule--helper.c
+++ b/builtin/submodule--helper.c
@@ -444,19 +444,19 @@ static void for_each_listed_submodule(const struct module_list *list,
 		fn(list->entries[i], cb_data);
 }
 
-struct cb_foreach {
+struct foreach_cb {
 	int argc;
 	const char **argv;
 	const char *prefix;
 	int quiet;
 	int recursive;
 };
-#define CB_FOREACH_INIT { 0 }
+#define FOREACH_CB_INIT { 0 }
 
 static void runcommand_in_submodule_cb(const struct cache_entry *list_item,
 				       void *cb_data)
 {
-	struct cb_foreach *info = cb_data;
+	struct foreach_cb *info = cb_data;
 	const char *path = list_item->name;
 	const struct object_id *ce_oid = &list_item->oid;
 
@@ -557,7 +557,7 @@ static void runcommand_in_submodule_cb(const struct cache_entry *list_item,
 
 static int module_foreach(int argc, const char **argv, const char *prefix)
 {
-	struct cb_foreach info = CB_FOREACH_INIT;
+	struct foreach_cb info = FOREACH_CB_INIT;
 	struct pathspec pathspec;
 	struct module_list list = MODULE_LIST_INIT;
 
-- 
2.20.1


```

## Junio C Hamano, 2020-04-03 00:20

Subject: Re: [PATCH 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
Message-ID: <xmqqo8s91ktt.fsf@gitster.c.googlers.com>
URL: https://gitlist.dev/e/xmqqo8s91ktt.fsf%40gitster.c.googlers.com
In-Reply-To: <20200402225807.8603-1-shouryashukla.oo@gmail.com>

```
Shourya Shukla <shouryashukla.oo@gmail.com> writes:

> Subcommands in 'submodule--helper.c' which give a callback to other functions
> have structures and macros named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT'
> respectively.
>
> The subcommand 'foreach' did not follow this convention and therefore had the naming of
> the form: 'struct foreach_cb' and 'CB_FOREACH_INIT'. Rename these to: 'struct foreach_cb'
> and 'FOREACH_CB_INIT' respectively.
>
>
> Shourya Shukla (1):
>   submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
>
>  builtin/submodule--helper.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)

Isn't this already in 'master'?


```

## Shourya Shukla, 2020-04-03 06:01

Subject: Re: [PATCH 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
Message-ID: <CAP6+3T2Kj2tfeaR+xm_B=_oJO8eWLyOjeXLm+8WSRSFSjkpUSQ@mail.gmail.com>
URL: https://gitlist.dev/e/CAP6%2B3T2Kj2tfeaR%2Bxm_B%3D_oJO8eWLyOjeXLm%2B8WSRSFSjkpUSQ%40mail.gmail.com
In-Reply-To: <xmqqo8s91ktt.fsf@gitster.c.googlers.com>

```
I apologize. I did not notice that my patch was merged.

Regards,
Shourya Shukla


On Fri, Apr 3, 2020 at 5:50 AM Junio C Hamano <gitster@pobox.com> wrote:
>
> Shourya Shukla <shouryashukla.oo@gmail.com> writes:
>
> > Subcommands in 'submodule--helper.c' which give a callback to other functions
> > have structures and macros named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT'
> > respectively.
> >
> > The subcommand 'foreach' did not follow this convention and therefore had the naming of
> > the form: 'struct foreach_cb' and 'CB_FOREACH_INIT'. Rename these to: 'struct foreach_cb'
> > and 'FOREACH_CB_INIT' respectively.
> >
> >
> > Shourya Shukla (1):
> >   submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
> >
> >  builtin/submodule--helper.c | 8 ++++----
> >  1 file changed, 4 insertions(+), 4 deletions(-)
>
> Isn't this already in 'master'?
>

```

## Junio C Hamano, 2020-04-03 17:58

Subject: Re: [PATCH 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
Message-ID: <xmqq1rp41mei.fsf@gitster.c.googlers.com>
URL: https://gitlist.dev/e/xmqq1rp41mei.fsf%40gitster.c.googlers.com
In-Reply-To: <CAP6+3T2Kj2tfeaR+xm_B=_oJO8eWLyOjeXLm+8WSRSFSjkpUSQ@mail.gmail.com>

```
Shourya Shukla <shouryashukla.oo@gmail.com> writes:

> I apologize. I did not notice that my patch was merged.

No need to be sorry ;-)  Thanks for contributing, and keep the good
patches coming!

```
