Re: [PATCH v3 00/10] Avoid the comma operator
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 29, 2025, 00:39 UTC
- Message-ID
- <xmqqtt7chdqd.fsf@gitster.g>
- In-Reply-To
- <504e63df-77d2-4cd0-bdcc-bd9949d34ce5@gmail.com>
Phillip Wood <phillip.wood123@gmail.com> writes:
Show 22 quoted lines
> Hi Johannes > > On 27/03/2025 11:52, Johannes Schindelin via GitGitGadget wrote: >> Changes since v2: >> * Made the sed construct in detect-compiler portable (thanks, Eric >> Sunshine!) >> * The majority of the feedback disagreed with the more compact format in >> diff-delta.c, so I changed it to the long format (thanks, Phillip Wood!) >> * The more succinct and safer, but less readable, cast in the loop >> condition of the dowild() function was replaced with the goto-based >> alternative I had mentioned as a possibility in the commit message >> (thanks, Phillip Wood!) >> * I adjusted the style of my compat/regex/ patch to the surrounding code's. >> * The -Wcomma option is now used in Meson-based clang builds, too (thanks, >> Patrick Steinhardt!) > > The range-diff below looks good to me, thanks for making our code base > clearer. > > Best Wishes > > Phillip
Yup, thanks Dscho, and all who gave valuable input to polish the series.
Will queue.