Re: [GSoC][PATCH v2 1/7] sequencer: make two functions and an enum from sequencer.c public
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jul 3, 2018, 20:20 UTC
- Message-ID
- <xmqqsh50oyu4.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <20180702105717.26386-2-alban.gruin@gmail.com>
Alban Gruin <alban.gruin@gmail.com> writes:
Show 6 quoted lines
> -enum check_level {
> - CHECK_IGNORE = 0, CHECK_WARN, CHECK_ERROR
> -};
> -
> -static enum check_level get_missing_commit_check_level(void)
> +enum missing_commit_check_level get_missing_commit_check_level(void)The new name definitely is better than "check_level" in the global context, but "missing_commit" is much less important thing to say than "this symbol is to be used when driving 'rebase' (or even 'rebase-i')", I think. "enum rebase_i_drop_commit_check" with "get_rebase_i_drop_commit_check()" perhaps?