Re: [GSoC][PATCH v2 1/7] sequencer: make two functions and an enum from sequencer.c public
- From
Alban Gruin <alban.gruin@gmail.com>
- Date
- Jul 5, 2018, 15:35 UTC
- Message-ID
- <d9ee3afd-2464-0a7c-d55f-951b89777d27@gmail.com>
- In-Reply-To
- <xmqqsh50oyu4.fsf@gitster-ct.c.googlers.com>
Hi Junio,
Le 03/07/2018 à 22:20, Junio C Hamano a écrit :
Show 15 quoted lines
> Alban Gruin <alban.gruin@gmail.com> writes:
>
>> -enum check_level {
>> - CHECK_IGNORE = 0, CHECK_WARN, CHECK_ERROR
>> -};
>> -
>> -static enum check_level get_missing_commit_check_level(void)
>> +enum missing_commit_check_level get_missing_commit_check_level(void)
>
> The new name definitely is better than "check_level" in the global
> context, but "missing_commit" is much less important thing to say
> than "this symbol is to be used when driving 'rebase' (or even
> 'rebase-i')", I think. "enum rebase_i_drop_commit_check" with
> "get_rebase_i_drop_commit_check()" perhaps?
> I don’t really like those names, but the function and the enum should eventually move to rebase-interactive.c and become static again, so we could revert their names in due course.
Cheers, Alban