git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 11/11] strvec: rename struct fields

From
Junio C Hamano <gitster@pobox.com>
Date
Jul 28, 2020, 21:16 UTC
Message-ID
<xmqqr1svcpcn.fsf@gitster.c.googlers.com>
In-Reply-To
<20200728202823.GK1021513@coredump.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 17 quoted lines
> The "argc" and "argv" names made sense when the struct was argv_array,
> but now they're just confusing. Let's rename them to our usual "nr" and
> "items" (which we use for string_list, as well as many ALLOC_GROW()
> arrays).
>
> Note that we have to update all of the callers immediately. Playing
> tricks with the preprocessor is hard here, because we wouldn't want to
> rewrite unrelated tokens.
>
> Signed-off-by: Jeff King <peff@peff.net>
> ---
> I'm actually not that fond of "items". I almost went with just:
>
>   const char **v;
>
> as the variable name which contains it usually provides sufficient
> context. But I worried that people would consider that too inscrutable.

I'd agree that v[] is a good name. If it is too short, I can live with item[], but not with items[]. Clearly we are mostly accessing one element at a time much more often than treating the set as a whole, so signaling "there are multiple things in the set" with a plural name is much less important than being able to say item[4] to name the 4th item in the collection.

Previous: Jeff KingNext: Junio C Hamano
Message 23 of 46 in “renaming argv_array”
  1. 0/11 renaming argv_arrayJeff King, Jul 28, 2020
  2. 01/11 argv-array: use size_t for count and allocJeff King, Jul 28, 2020
  3. 02/11 argv-array: rename to strvecJeff King, Jul 28, 2020
  4. 03/11 strvec: rename files from argv-array to strvecJeff King, Jul 28, 2020
  5. 04/11 quote: rename sq_dequote_to_argv_array to mention strvecJeff King, Jul 28, 2020
  6. 05/11 strvec: convert builtin/ callers away from argv_array nameJeff King, Jul 28, 2020
  7. 06/11 strvec: convert more callers away from argv_array nameJeff King, Jul 28, 2020
  8. 07/11 strvec: convert remaining callers away from argv_array nameJeff King, Jul 28, 2020
  9. 08/11 strvec: fix indentation in renamed callsJeff King, Jul 28, 2020
  10. Jacob KellerJul 28, 2020
  11. Junio C HamanoJul 28, 2020
  12. 09/11 strvec: update documention to avoid argv_arrayJeff King, Jul 28, 2020
  13. 10/11 strvec: drop argv_array compatibility layerJeff King, Jul 28, 2020
  14. Junio C HamanoJul 28, 2020
  15. Jeff KingJul 29, 2020
  16. Jeff KingJul 29, 2020
  17. Jeff KingJul 29, 2020
  18. Junio C HamanoJul 29, 2020
  19. Derrick StoleeJul 29, 2020
  20. Junio C HamanoJul 29, 2020
  21. Jeff KingJul 29, 2020
  22. 11/11 strvec: rename struct fieldsJeff King, Jul 28, 2020
  23. Junio C HamanoJul 28, 2020
  24. Junio C HamanoJul 28, 2020
  25. Christian CouderJul 29, 2020
  26. Jeff KingJul 29, 2020
  27. Junio C HamanoJul 29, 2020
  28. Jeff KingJul 28, 2020
  29. Jacob KellerJul 28, 2020
  30. Jeff KingJul 29, 2020
  31. Christian CouderJul 29, 2020
  32. Christian CouderJul 29, 2020
  33. Eric SunshineJul 29, 2020
  34. Jeff KingJul 29, 2020
  35. René ScharfeAug 11, 2020
  36. Taylor BlauAug 11, 2020
  37. Junio C HamanoAug 11, 2020
  38. Jacob KellerAug 11, 2020
  39. Junio C HamanoAug 11, 2020
  40. Johannes SchindelinAug 12, 2020
  41. Jeff KingAug 12, 2020
  42. Jeff KingAug 12, 2020
  43. René ScharfeAug 12, 2020
  44. Jeff KingAug 12, 2020
  45. René ScharfeAug 12, 2020
  46. Jeff KingAug 12, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.