Re: [PATCH 0/11] renaming argv_array
- From
Jeff King <peff@peff.net>
- Date
- Jul 29, 2020, 00:06 UTC
- Message-ID
- <20200729000628.GB1623001@coredump.intra.peff.net>
- In-Reply-To
- <CA+P7+xqrV7yvQ2XihDnjuuT5Ro0_qvb4WS6tNH2GGn5DQzoLNw@mail.gmail.com>
On Tue, Jul 28, 2020 at 03:45:08PM -0700, Jacob Keller wrote:
> One thing I thought I would see but I guess we simply don't have one > is a technical doc that details the strvec. I guess we just never had > one for argv_array? Probably worth adding one at some point.
It all got moved into the header file in 971b1f24a2 (argv-array: move doc to argv-array.h, 2019-11-17). It got the same s/argv_array/strvec/ as the code in patch 2. I think what's there is pretty reasonable, but patches welcome if you have suggestions about what could be added. :)
-Peff