git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 10/11] strvec: drop argv_array compatibility layer

From
Junio C Hamano <gitster@pobox.com>
Date
Jul 29, 2020, 00:47 UTC
Message-ID
<xmqqlfj3b0zy.fsf@gitster.c.googlers.com>
In-Reply-To
<20200729004009.GB1653374@coredump.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 9 quoted lines
> And here's a diff between your current "seen" tip and what I get by
> merging in this updated version and then doing any necessary resolution
> or fixups on top. I'll leave it as an exercise for how you might want to
> pull the content across. :)
>
> I do note that most of the new call-sites are ones that would be better
> off using child_process.args, and reviewers (myself and others) have
> suggested that. So those direct uses of the "argv" member may go away
> anyway.

Yup, I do not think we should spend too much cycles on this at this point, as Stolee's topic and others that add new callsites are likely to be rerolled at least one more time.

It is tempting to declare that these 11 patches are now perfect and we'll stop the world and fast-track it down to 'master', while discarding any and all topics in flight that changes anything related to argv-array, and then we ask authors of these discarded topics to send in a rebase on top of the 'master' with strvec API already in. But I somehow think we do not have to take such a drastic measure to adjust the world around this topic ;-)

Previous: Jeff KingNext: Derrick Stolee
Message 18 of 46 in “renaming argv_array”
  1. 0/11 renaming argv_arrayJeff King, Jul 28, 2020
  2. 01/11 argv-array: use size_t for count and allocJeff King, Jul 28, 2020
  3. 02/11 argv-array: rename to strvecJeff King, Jul 28, 2020
  4. 03/11 strvec: rename files from argv-array to strvecJeff King, Jul 28, 2020
  5. 04/11 quote: rename sq_dequote_to_argv_array to mention strvecJeff King, Jul 28, 2020
  6. 05/11 strvec: convert builtin/ callers away from argv_array nameJeff King, Jul 28, 2020
  7. 06/11 strvec: convert more callers away from argv_array nameJeff King, Jul 28, 2020
  8. 07/11 strvec: convert remaining callers away from argv_array nameJeff King, Jul 28, 2020
  9. 08/11 strvec: fix indentation in renamed callsJeff King, Jul 28, 2020
  10. Jacob KellerJul 28, 2020
  11. Junio C HamanoJul 28, 2020
  12. 09/11 strvec: update documention to avoid argv_arrayJeff King, Jul 28, 2020
  13. 10/11 strvec: drop argv_array compatibility layerJeff King, Jul 28, 2020
  14. Junio C HamanoJul 28, 2020
  15. Jeff KingJul 29, 2020
  16. Jeff KingJul 29, 2020
  17. Jeff KingJul 29, 2020
  18. Junio C HamanoJul 29, 2020
  19. Derrick StoleeJul 29, 2020
  20. Junio C HamanoJul 29, 2020
  21. Jeff KingJul 29, 2020
  22. 11/11 strvec: rename struct fieldsJeff King, Jul 28, 2020
  23. Junio C HamanoJul 28, 2020
  24. Junio C HamanoJul 28, 2020
  25. Christian CouderJul 29, 2020
  26. Jeff KingJul 29, 2020
  27. Junio C HamanoJul 29, 2020
  28. Jeff KingJul 28, 2020
  29. Jacob KellerJul 28, 2020
  30. Jeff KingJul 29, 2020
  31. Christian CouderJul 29, 2020
  32. Christian CouderJul 29, 2020
  33. Eric SunshineJul 29, 2020
  34. Jeff KingJul 29, 2020
  35. René ScharfeAug 11, 2020
  36. Taylor BlauAug 11, 2020
  37. Junio C HamanoAug 11, 2020
  38. Jacob KellerAug 11, 2020
  39. Junio C HamanoAug 11, 2020
  40. Johannes SchindelinAug 12, 2020
  41. Jeff KingAug 12, 2020
  42. Jeff KingAug 12, 2020
  43. René ScharfeAug 12, 2020
  44. Jeff KingAug 12, 2020
  45. René ScharfeAug 12, 2020
  46. Jeff KingAug 12, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.