Re: t6044 broken on pu
- From
Junio C Hamano <gitster@pobox.com>
- Date
- May 8, 2016, 18:20 UTC
- Message-ID
- <xmqqoa8gza1t.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <5618208c-ce45-d65c-abf8-498cfe0f2f84@web.de>
Torsten Bögershausen <tboegi@web.de> writes:
> May a simple > printf "1\n2\n3\n4\n5\n6\n7\n8\n9\n10\n" > > be an option ?
If you were to do that, at least have the decency to make it more readable by doing something like:
printf "%s\n" 1 2 3 4 5 6 7 8 9 10
;-)
But as I said, as a response to "t6044 broken on pu" bug report, s/seq/test_seq/ is the only sensible change.
Improving "test_seq, the alternative to seq" is a separate topic.
If you have aversion to $PERL, perhaps do them without using anything what is not expected to be built-in in modern shells, perhaps like this?
t/test-lib-functions.sh | 7 ++++++- 1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/t/test-lib-functions.sh b/t/test-lib-functions.sh index 8d99eb3..4edddac 100644 --- a/t/test-lib-functions.sh +++ b/t/test-lib-functions.sh @@ -739,7 +739,12 @@ test_seq () { 2) ;; *) error "bug in the test script: not 1 or 2 parameters to test_seq" ;; esac - perl -le 'print for $ARGV[0]..$ARGV[1]' -- "$@" + test_seq_counter__=$1 + while test "$test_seq_counter__" -le $2 + do + echo "$test_seq_counter__" + test_seq_counter__=$((test_seq_counter__ + 1)) + done } # This function can be used to schedule some commands to be run